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Preface

& About This Guide

& Product Enhancements

& Related Publications

& World Wide Web Information
¢ Getting Help

About This Guide

The TrackRecord User’s Guide is intended for users of TrackRecord. It
includes information designed to aid users by providing information
about TrackRecord’s concepts and user interface, instruction on entering
information into TrackRecord, using predefined reports to display the
contents of the TrackRecord database, and formatting custom Track-
Record reports. You can find additional information in the online help
facility and documentation set. See “Related Publications” on page 8.

Compuware assumes that you are familiar with basic Microsoft Windows
navigation. If this is not the case, familiarize yourself with the documen-
tation for Microsoft Windows before reading this guide.

Product Enhancements

For a detailed listing of product enhancements made in TrackRecord
Release 06.01, refer to the “What’s New” in the TrackRecord Release
Notes. In addition to the most recent release, the Release Notes also list
enhancements included in several previous releases for your reference.



Related Publications
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The TrackRecord documentation set contains:

¢ Installation Guide— PDF file containing system requirements and
instructions for installing and configuring Compuware products.

& Licensing Guide— PDF file containing licensing procedures and over-
view.

& TrackRecord Administrator’s Guide— Description of various administra-
tive tasks that must be performed before TrackRecord can be used and
the actions required to create and maintain the TrackRecord database
and AutoAlert. It also includes reference material for programmers
writing modules to access the TrackRecord databases.

¢ The TrackRecord online help— Field descriptions, operating proce-
dures, and reference information relating to TrackRecord. In the Web-
Server, click Help to see an outline of available topics. In the
Windows Client, click Help or press F1.

¢ TrackRecord Release Notes— HTML file that contains technical
information that may affect how you use the product and known
issues related to the current release of TrackRecord. You can find the
Release Notes in the TrackRecord program files.

¢ TrackRecord Guided Tour— A quick tour of the product containing
product overview information, user interface descriptions, and an
overview of the basic tasks that can be performed with the product.
You can access the tour by choosing Guided Tour from the Track-
Record program files or from the Help menu within the product.

You can access the online versions of the PDF files from the installation
bookshelf on the TrackRecord CD browser or from Compuware’s Front-
Line technical support Web site at: http://frontline.compuware.com.

Viewing and Printing Online Books

TrackRecord’s online books are provided in PDF format, so you need
Adobe Acrobat Reader to view them. It is recommended that you install
Acrobat Reader 4.0 or above to get the best results when viewing the
online books. To install the Adobe Acrobat Reader, go to Adobe’s Web site
at www.adobe.com.

Because PDF is based on PostScript, a PostScript printer is the most
reliable way to print the online books. In most cases, you can also print
PDF files to PCL printers. If you cannot print the PDF files to your printer,
refer to Adobe’s Web site for trouble-shooting information.


http://frontline.compuware.com
http://www.adobe.com

World Wide Web Information

Getting Help

Tip: To display the
TrackRecord About
window, choose
Help>About Compuware
TrackRecord. Click OK
when you are finished.

To access Compuware Corporation’s site on the World Wide Web, point
your browser at http://www.compuware.com. The Compuware site
provides a variety of product and support information.

FrontLine Support Web Site

You can access online technical support for Compuware products via our
FrontLine support Web site at http://frontline.compuware.com. Front-
Line provides fast access to critical information about your TrackRecord
product. You can read or download documentation, frequently asked
questions, and products fixes, or email your questions or comments. The
first time you access FrontLine, you are required to register and obtain a
password.

At Compuware, we strive to make our products and documentation the
best in the industry. Feedback from our customers helps us maintain our
quality standards. If you need support services, please obtain the follow-
ing information before calling Compuware’s 24-hour product support
hotline:

¢ The name and release (version) number of the TrackRecord product.
This information is found on the covers of the product documenta-
tion or the About Compuware TrackRecord window.

¢ Installation information including:

¢ Installed options
Whether the product uses local or network databases
Whether it is installed in the default directories
Whether it is a standalone or network installation
Whether it is a client or server installation

(ORI IR

¢ Environment information, such as the operating system and release
on which the product is installed, memory, hardware/network speci-
fications, and the names and releases of other applications that were
running.

¢ The location of the problem in the TrackRecord product software,
and the actions taken before the problem occurred.

¢ The exact product error message, if any.
¢ The exact application, licensing, or operating system error messages,

if any.

¢ Preface 9
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¢ Your Compuware client, office or site number if available.
TrackRecord Technical Support

Compuware Corporation
31440 Northwestern Highway

Farmington Hills, M1 48334-2564
1-800-538-7822
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Chapter 1

Introducing TrackRecord

& Overview of TrackRecord

& Process at a Glance

& About the TrackRecord Database

4 Understanding Data Type Inheritance

Overview of TrackRecord

Product Integration

Note: This chapter provides a summary of Compuware TrackRecord®.
Because it provides an overview of TrackRecord functions and
concepts, you should read this chapter carefully before you use
TrackRecord for the first time.

Compuware TrackRecord is a defect and project tracking tool designed to
record and report information about products being developed or
supported. TrackRecord records all the information relating to a project-
project Team Members and testers, schedules and milestones, bug reports
and feature requests- in a database. You can then use TrackRecord’s query
and reporting features to retrieve and format the information you need
to keep your project on track.

TrackRecord is very customizable and can adapt to virtually any environ-
ment. With TrackRecord, you can track many types of information,
implement full workflow to ensure a repeatable process, create multiple
reports, and even generate graphs.

TrackRecord is part of the Compuware DevPartner Studio suite of
software debugging tools and the Compuware QACenter family of
automated testing tools. Interaction with these families of products is

11



Types of Users

described in Chapter 8, “Integrating TrackRecord with Other Applica-
tions”.

Figure 1-1 illustrates how TrackRecord users, administrators, and
WebServer users interact with the TrackRecord server and database.

If you have a license to use TrackRecord on multiple PCs, you can install
TrackRecord on a dedicated PC to act as your server. The server will house
the database and will share it with the client workstations.

As information is entered in TrackRecord, the information is stored in a
database. Interaction with this database occurs through queries and
reports, as described in “Process at a Glance” on page 13. For more infor-
mation about the database, see “About the TrackRecord Database” on
page 15.

Figure 1-1. TrackRecord Users and Components

TrackRecord TrackRecord
Windows WebServer
Client Users Client Users

qo-

C [*nd
;

*-¢ e _»‘

There are three types of TrackRecord users:

¢ TrackRecord Administrator — TrackRecord includes administrative
functions that can only be performed by authorized users, such as
setting up user groups, importing and exporting information to and
from other applications, and editing the data types used by Track-
Record. When a TrackRecord administrator logs in, he or she sees an
additional menu (the Administrator menu) on the TrackRecord menu
bar. For additional information, refer to the TrackRecord Administra-
tor’s Guide.

12 TrackRecord User’s Guide



¢ TrackRecord Windows Client User — A user running the Track-
Record client software accesses the TrackRecord database by logging
in from client machines anywhere on your network. Whether a user
can add or modify database information, including items and
reports, depends on the groups to which the user belongs. The
administrator determines the access and editing privileges of each
user.

¢ TrackRecord WebServer User — WebServer users access the database
by logging in using standard Web browsers, such as Microsoft Inter-
net Explorer or Netscape Navigator. Refer to Chapter 6, “Using Track-
Record’s WebServer” for information on the WebServer interface.

Process at a Glance

TrackRecord can be used to enter information about projects and to
retrieve and view that information. This section provides an overview of
those fundamental tasks. The example shown in Figure 1-2 depicts a

Chapter 1 e Introducing TrackRecord 13



visual overview of task to create a report of all defects in the database that
are assigned to Your Project and have a priority of 1 (Critical) or 2 (High).

Figure T-2. Process at a Glance. Note that your screens may be different than shown.
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tion b Keywords

¥ Operating Syskem
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B
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e
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@ Your Project Priorities 2
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+000013: Crashes on Save

o
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3. View data that has been
retrieved by a query. Four
formats are available: Outline
Report, Graph, Milestone Status,
or a Calendar. In this example, an
Outline Report has been used to
display the information. Refer to
Chapter 5, “Viewing Data” for
complete information.
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About the TrackRecord Database

Understanding how the TrackRecord database records, links, and displays
information is an important step toward using the product more effec-
tively.

When you enter information using TrackRecord, the information is
stored in a database. TrackRecord automatically opens its database when
you start the program, and automatically closes your connection to the
database when you exit. You interact with this database through item
views, queries, and report views, as described in “Process at a Glance” on
page 13.

Types, Items, Links, and Fields

The TrackRecord database organizes information into types, such as
Person, Company, Defect, or Project. For each type of information stored
in the TrackRecord database — defects, tasks, Team Members, and so on
— you will want to store different pieces of information.Each data type
functions like a database table, establishing the properties (fields) Track-
Record expects for an item of that type. Visually, a data type is a form,
with fields and controls to enter or display information. These types are
extremely customizable and many different fields can be added or
removed very easily. For example, you might want to store a name and
phone number for a Team Member and a summary and description for a
defect.

A data item is one record of a specific type that has its own data entry
form, which is composed of fields appropriate to that item type. For
example, Abraham Lincoln and Harry Truman would be two items of the
type Person in a TrackRecord database.

Each data item consists of fields and links. Fields hold specific facts about
an item, such as a person’s address or the name of a project; links
connect one item in the TrackRecord database to another to capture the
relationships between items. For example, a Team Member item (John
Doe) might be connected to Project items (as a Team Member), Defect
items (as the person reporting them or responsible for fixing them), and
Company items (as an employee).

Figure 1-3 illustrates how a Team Member item links to a Company item
and to several Project items. These links make it easy to retrieve informa-

Chapter 1 e Introducing TrackRecord 15



Change History

tion, such as all Team Members assigned to a Project or all Projects with
open defects.

Figure 1-3. Links Between Database Items

TEAM MEMBER
TEAM MEMBER

Last. First Migdle:
Carter Edison T.

Tampany: Gmpany:
_-—
Yoyodyne Inc, Yoyodyne Inc.

ess: ess:
123 Main Street 9 Townsend West

City: St Zp: Cauntry: 3 St Zp: Gountry:
Nashua NE 03063 UsA Nashua KH 03063 USA

Projects:
Bullwinkle
Natasha
Roc!

PROJECT

“Projsct Name: Active ¥
Rocky

Description:
New spreadshest application

Dosuments:
Design Specification
UI Specification
Marketing Requirements

When an object is entered in a field, that field is automatically linked to
the original item. When you change the item, no matter where it
appears, all references to that item change automatically. For example, if
you change the spelling of the Person’s name, that change is reflected in
all other items that contain a link to that Person.

In addition to the obvious information types, such as Projects or People,
the TrackRecord database can store special types of information, such as
executable commands and database queries.

As database items are created and modified, TrackRecord captures the
time and date of each change, the person adding or changing the item,
and the information that was added or changed. For more information
regarding change history, refer to “Change History Tab” on page 37.

Client-Server Technology

The TrackRecord database resides on a central server on your network.
The TrackRecord server software accepts simultaneous input from multi-
ple users on client machines; the TrackRecord server periodically checks
the database for new information during a session and forwards updated
information to clients when necessary.

16  TrackRecord User’s Guide



Understanding Data Type Inheritance

TrackRecord information types, such as the Person type, Defect type, and
so on, provide the framework on which the TrackRecord database is built

and is organized into a data hierarchy.

When one type inherits from another, the inheriting type (the child)
receives all the attributes of the original type (the parent). In the example
(Figure 1-4, Data Type Inheritance, on page 17), Bugs is the parent of
Open Bugs, and Open Bugs is the parent for Priority 1 and Priority 2;
Open Bugs and Closed Bugs are the child of Bugs, and Priority 1 and

Priority 2 are the child of Open Bugs.

Figure 1-4. Data Type Inheritance

Eugs

“Open Bugs” inherits
attributes of “Bugs”

Open Bugs
Friarity 1
Friarity 2

Children of “Open Bugs”
+——and inheritors of its

attributes
“Closed Bugs”, the child

Closed Bugs

type, inherits attributes of
“Bugs”, the parent type

After the child inherits fields from the parent, it can add fields of its own.
Figure 1-5 illustrates how the Person data type is the parent to the Devel-
oper and Beta Tester data types; each child type starts with the fields it

inherits from the Person type, and adds its own fields below the inherited

fields.

Figure 1-5. Child Items Inherit Fields from Parent

Last:

TEAM MEMBER
L

Address

Last

]

Company:

New

fields

Address:

The Developer and Tester

types inherit from the
Person type, taking all of
the fields from Person

oty

os:

C—1

Hardware Cmﬂ% Last Comacted:

Bata Coordinator:

before adding others.
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This type of inheritance allows items of any child type to be used
anywhere in TrackRecord where an item of its parent type is expected.
For example, Figure 1-5 illustrates that the Team Member type inherits
from the Person type, so all Team Member items are also Person items.
Therefore, Team Members and Testers can be used to fill fields where
Person items are expected. Note, however, that the reverse is not gener-
ally true: Person items that are not Team Members cannot be used in
fields where Team Members are required.

One of the benefits that type inheritance provides is the ability to add
another identity to an item of one type. For example, a person in a
database changes roles on a project and must be changed to a Team
Member. If Team Member is a child type of the Person type, an adminis-
trator does not need to remove and reenter information about that
individual.

Type inheritance also permits querying on a parent type to retrieve infor-
mation about all items of that type, including its child types. For
example, a query that looks for defects will retrieve items of the parent as
well as the child.

Where to Go Next

Now that you have a general understanding of TrackRecord concepts,
you are ready to get up and running with TrackRecord. Refer to Chapter
2, “Getting Started” for more information.

TrackRecord User’s Guide



Chapter 2

Getting Started

¢ Before You Begin

& Starting TrackRecord

& Exploring TrackRecord'’s User Interface
& Working With the Item Browser

® Accessing TrackRecord Online Help

& Searching the TrackRecord Database
& Customizing User Preferences

Before You Begin

Before you begin using TrackRecord, you will need to obtain the follow-
ing information from your TrackRecord administrator:

4

What user name and password should you use?

Before you can log in to TrackRecord, you must have a valid user
name and password.

What database should you use?

If your site has several development projects running concurrently,
your TrackRecord administrator might create separate databases. You
will need the name of your database.

What project should you use?

A database can include multiple projects. Your TrackRecord adminis-
trator can tell you what project name you should use to display and
enter project information.

Note: TrackRecord Administrators should refer to the TrackRecord Adminis-

trator’s Guide for information about setting up the database before
users begin creating items.

19



Note: For information on using the TrackRecord WebServer, refer to

Chapter 6, “Using TrackRecord’s WebServer”.

Starting TrackRecord

20

Follow the instructions below for quickly getting started with Track-
Record.

1

TrackRecord User’s Guide

Open TrackRecord by clicking the task bar’s Start button on your
Windows desktop and choosing TrackRecord from the program files.

The TrackRecord Login dialog box (Figure 2-1) appears. If your Track-
Record user information has been set to automatically log in to Track-
Record, the dialog box will not be displayed.

Figure 2-1. TrackRecord Login Dialog Box

TrackRecord Login

Mame: I Adrmin

k|
Password: I |

Datahase: I demo j

Ok I Cancel |
On the TrackRecord Login dialog box,

¢ Enter your TrackRecord login name and password. Note that they
may be different from your Windows login name and password.
Passwords are case-sensitive.

¢ Identify the database you want TrackRecord to use in the Data-
base field by selecting a name from the drop-down list or by
entering a new name.

If you have used TrackRecord before, the names of the databases
you have used previously appear in the Databases list. You do
not need to enter the path to the database, just the database
name.

Click OK. The main TrackRecord window (Figure 2-3) appears and
displays any subwindows left open from your previous session. If
your TrackRecord Administrator has created a Home page, the Home

page appears.



Changing Your Login Password

To ensure the security of the information in a TrackRecord database, the
first task you should perform with TrackRecord is to change your login
password.

Note: If you or your Administrator has created your user profile to allow
you to automatically log in when you start TrackRecord, this task is
not necessary.

You can change your TrackRecord login password at any time. To change
your password:

1 From the Tools menu, choose Change Password. The Change Pass-
word dialog box (Figure 2-2) appears.

Figure 2-2. Change Password Dialog Box

Change Password 2| %]

Change password For Admin oK |
|I\Iew password: Cancel |

Confirm new password: H;lpl

2 Enter your new password in the New Password field and the Con-
firm New Password field.

Tip: If you do not wish to To prevent anyone from observing what you type, TrackRecord
use a password, leave the displays an asterisk for each character you enter. Passwords are case-
password fields blank. sensitive.

3 Click OK. Your new password takes effect immediately.

Chapter 2 ¢ Getting Started 21



Exploring TrackRecord’s User Interface

Menu Bar

Before you begin using TrackRecord, you should take a few minutes to
explore its windows, tool bar, and status bar.

Figure 2-3. TrackRecord Main Window. Since various aspects of this window can be
customized, yours may vary from the example.

= TrackRecord - [Defects Assigned to Me] ;IQILI
[5 File Edit Wiew Administrator Favorites Tools Window Help ;Iill“
Menu bar Ml Mew Defect = g = | 3] | ﬁ |JJSearch Al iterns - for Ga |
Toolbar §| 2= Insert Header = ‘v"\| ﬂl| Options. .. | Up to Date |
G to me -
@ Unreviewed {0 items) _I
© Open (D items)
D|sp|ay area © Pending Yalidation {0 items)
User name

Server name

User name \\ \ \—H

Status bar 0items, defaultgpohnson PRODTLCOMPLWARE., COMyAdmin)

The main TrackRecord window (Figure 2-3) displays a menu bar below
the window title.

Table 2-1. TrackRecord Menu Bar

Menu Item Functionality

File Create new items and reports, open and manage predefined
reports, queries, and templates, and lists items you have
recently worked with. Also includes standard File menu entries,
such as Print Setup, Print, and Exit.

Edit Copy and paste text and graphics from one place to another.
Contents change according to which window is active within
TrackRecord.

Administrator (Displayed only if you log in with Administrator access). Create

users and user groups, edit data types and user defaults, and
import and export data and type descriptions.
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Toolbar

Table 2-1. TrackRecord Menu Bar

Menu Item Functionality

Favorites Specify frequently used reports. After adding a report to the
Favorites menu, run it by choosing its name from the menu.
Also specify one report as your Home Page to open automati-
cally when you log in.

Tools Search the database for items that meet specified criteria, log
in as another user, browse items, and modify options.

Window Position windows and switch from one window to another.

Help Access online documentation, the Guided Tour, and the About
TrackRecord dialog box, which displays registration and soft-
ware release information.

The tool bar (Figure 2-4) contains shortcuts to your most commonly
performed tasks. It lets you create a new item or view, open an existing
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item, display the Item Browser, open your Home Page, or search for

items.

Figure 2-4. Toolbar

pen ltem ldmin

New ltem

Table 2-2. TrackRecord Tool bar

Toolbar Item  Functionality

New ltem

e Create a new item or view. The item types listed on the
drop-down list are determined by your Favorite Types list (as
described in the TrackRecord Administrator’s Guide).

e Control the new item type shown on the Toolbar with your
Favorite Types list. For example, if you most often create
new Tasks, you would move Task to the top of your Favorite
Types list and the Toolbar would show New Task rather than
New Defect, which is the default.

Open Item

Open an existing item or view. The Open dialog box is
described in “Opening, Modifying, and Deleting Views” on
page 54.

Item Browser

Displays the Item Browser. The Item Browser is described in
“Working With the Item Browser” on page 25.

Open Home
Page

Opens your Home Page report. Setting a Home Page is
described in “Identifying Favorite Reports and Home Pages” on
page 31.

Search

Search items in the TrackRecord database for a specified string.
Control whether TrackRecord displays the Search tool by right-
clicking anywhere in the Tool bar area and toggling Search off.
To display the Search tool, right-click in the Tool bar area and
toggle Search on. Refer to “Searching the TrackRecord Data-
base” on page 27 for additional information on searching.
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Status Bar

The left side of the Status bar (Figure 2-3) provides suggestions for the
actions you can perform with a tool or on a selected object. If you are
working in an Outline Report, the status bar identifies the sequence
number of the item you have selected and the number of items in the
sequence.

The right side of the status bar displays the database name, server name,
and the login name of the current user. For example, the database
"default", the server name “sfal0072”, and the username "Admin" would
appear as: default|sfal0072:Admin

Working With the Item Browser

The Item Browser window (Figure 2-5) provides access to information in
your TrackRecord database. With the Item Browser, you can access exist-
ing database items of any type or create new items.

Figure 2-5. Item Browser Window
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The Item Browser window includes two lists:

¢ The Types list identifies the basic types of information in the Track-
Record database. If one type of information is a subtype of another, it
appears indented below that type. For example, Team Member is a
subtype of the Person data type in Figure 2-5.

¢ The Items list identifies all of the items of the selected type. When
you select a type that has subtypes, the names of all the members in
the subtypes appear. For example, if you choose Person, the Items list
will include the names of all Team Member items (subtype of Person)
as well as all Person items.
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Tip: TrackRecord often
presents several ways to
accomplish a task. For
example, you can open
the Item Browser with the
Tool bar button, from the
Tools>Item Browser
option, or from the
File>Open>Other option.

Note: The list of types that you see might be a subset of the types available.

The administrators control your access to types.

Using the Item Browser

To use the Item Browser, perform the following steps:

1

Click the Item Browser button (Figure 2-6) on the tool bar to open
the Item Browser window.

Figure 2-6. Locating Item Browser Button on Toolbar

File Edit Administrator Fawvortes Tools Window Help

New Defect = WF"'| ) | ﬁ JJSearch Al items - Far Ga

Select the type of item about which you want information.

For example, select Person to see the list of all Person items in the
TrackRecord database. Note that the list will include all items linked
to the type you selected; therefore, selecting Person will show a list of
Persons, Customers, and Team Members in the Item list.

Double-click an entry in the Items list to display the item’s contents.

For example, double-clicking the name of a Person in the Items list
opens the appropriate item view, letting you view and modify the
information recorded for that Person.

Note that if you select an item that belongs to a child type of the data
type you chose, TrackRecord opens the item view for the child. For
example, if you choose Person and then double-click the name of
someone who is a Team Member (child of Person), TrackRecord
opens the Team Member item view instead of the Person item view.

Accessing TrackRecord Online Help

| Help
{8 Tockncond Help

| About Campuware TrackRiecord..

TrackRecord’s online help facility is a convenient way to find informa-
tion about a task you are performing, a feature you would like to know
more about, or a command you want to use. It also contains complex
information for an administrator that is not contained in the TrackRecord
User’s Guide.

¢ While performing certain tasks, you may press the F1 key to open the
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online help system and display a help topic appropriate for the task
you are performing.

Selecting the TrackRecord Help option on the Help menu displays a
window containing TrackRecord’s help system. You can located infor-
mation quickly through the Contents, Index, or Search tabs.



Topics may contain links to other topics or links to popup frames. To
close a popup frame, click anywhere inside the popup.

Searching the TrackRecord Database

To find database information quickly, you can perform a search rather
than create a query and view. Simple searches find text strings that occur
in an item; advanced searches find text strings in specific fields.

Performing a Simple Search

A simple search lets you find items of a specified type that contain a
specified text string. For example, you can search for all defect items that
contain a specific name in any field.

1

From the Tools menu, choose Search to open the Search dialog box
(Figure 2-7).

You can use the Search tool on the main TrackRecord window to
perform the same function as the Search menu option.

Figure 2-7. Search Dialog Box
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To search for a specific type of item, select the type from the Search
for Items of Type drop-down list.

To search through the entire database, select All Items from the
Search for Items of Type drop-down list.

Enter the text string you want to find in the That Contain field.

Any item that contains the specified text string in any field will be
displayed. You can enter partial words to find wording variations. For
example, you can enter veri to find all items that include the words
verification, verify, verified, or unverified.

Click the Search button. A counter displays in the left corner of the
status bar, indicating the progress of the search.

The Search dialog box lists all items that meet your search criteria. To
display the contents of one of the items, double-click the appropriate
entry.

When you are finished, click Close.
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Performing an Advanced Search

Advanced searches let you refine the criteria you want TrackRecord to use
to search in the database. Unlike a standard search, an advanced search
lets you specify the fields to check for text strings and lets you construct
multiple search criteria. For example, you can perform an advanced
search to find all defects where the project name is YourProject, the sever-
ity level is 3, and the description includes the phrase “only happens.”

Complete the following procedure to perform an advanced search:

1 From the Tools menu, choose Advanced Search. The Choose a Type
dialog box (Figure 2-8) displays your list of standard database types.

Figure 2-8. Choose Type Dialog Box
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Close | Help |

2 Select the type of information you want to find and click the Search
button.

TrackRecord opens the form associated with the type of information
you selected. For example, if you selected Defect, TrackRecord would
open the Defect form.

3 Use the fields and controls on the item form to specify your search
criteria.

For example, you can use the Project list to select the project for
which you want to find Defect items. Similarly, you can enter a text
string in the Description field to find all defects whose description
starts with those words. If you specify more than one search criterion,
TrackRecord finds all items that meet all of the search criteria.
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4 Click the Search button. TrackRecord displays the Search Results dia-
log box (Figure 2-9), which lists the items that meet your search crite-
ria.

Figure 2-9. Search Results Dialog Box
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5 Display the contents of a selected item by double-clicking an entry in
the Search Results dialog box or select an entry and click the Open
button. TrackRecord displays the contents of the specified item.

6 When you are finished, click the Close button.

Customizing User Preferences

After you become familiar with TrackRecord, you will probably want to
customize your user options to suit your style of work. TrackRecord user
preferences fall into three categories:

¢ Configuring General Options — Configure your system to control
how TrackRecord behaves at startup, database-polling frequency, and
how it interacts with DevPartner tools.

¢ Identifying Favorite Reports and Home Pages — Information on add-
ing reports to a favorites menu and changing a home page.

¢ Specifying Favorite Data Types — Simplify data entry by setting up a

list of your favorite data types.

Configuring General Options

The General tab on the TrackRecord Options dialog box controls how
TrackRecord behaves at startup, how frequently it polls its database, and
how it interacts with DevPartner tools. To configure general options,
execute the following procedure:
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From the Tools menu, choose TrackRecord Options. The Track-
Record Options dialog box (Figure 2-10) appears.

Figure 2-10. TrackRecord Options Dialog Box — General Tab
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On the General tab, specify what TrackRecord should do when you
open a new session.

¢ To preserve your window layout from one session to the next,
select the Open the windows that were open at the end of the
last session option.

¢ To display your Home Page at the start of a session, select the
Open the current Home Page option.

If you want to log in to TrackRecord without entering your user name
and password, select the Automatically log in at startup checkbox.

If you activate this checkbox, whenever you start TrackRecord you
will be automatically logged in and, since you will not be prompted
for a database name, you will always access the same database.
Anyone running TrackRecord on your computer will automatically
be logged in to the last TrackRecord account and database that you
used from TrackRecord or from one of the integrated tools.

Use the Check the Database for Changes slider to specify how fre-
quently TrackRecord should poll its database for changes.

Polling the database frequently ensures that TrackRecord is working
with current information but may slow other operations on your
computer. If your network link is slow or if you are using Outline
Reports that are not likely to change frequently, you may want to
check the database less often.



5 If you are using the DevPartner tools and want TrackRecord to record
information from DevPartner tools automatically, select the Auto-
matically Submit Sessions from DevPartner Tools checkbox.

6 Click OK.

Identifying Favorite Reports and Home Pages

Favorite Reports are reports or views that you use frequently. Identifying
a view or report as a Favorite Report lets you open it from the Favorites
menu instead of through the File menu.

A Home Page is a report that opens automatically when you start Track-
Record, and can be accessed quickly through the Home Page button on
the Tool bar. If you are using the WebServer browser interface, your
Home Page is accessible through a button in the control area.

Project administrators can create one or more favorite views for new
users during TrackRecord setup and can set default Home Pages. You can
modify these settings.

Adding a Report To Your Favorites Menu
1 Open the report or view you want to identify as a favorite.

2 With the Report dialog box active, from the Favorites menu, choose
Add to Favorites. The title of your report appears on the Favorites
menu.

Changing Your Home Page
1 Open the report or view you want to identify as your Home Page.

2 With the Report dialog box active, from the Favorites menu, choose
Set as Home Page.

Specifying Favorite Data Types

TrackRecord lets you create a list of your favorite data types to simplify
data entry. It controls which data types appear in the File>New
submenu, in the New list on the tool bar, and in the Search Types list.
The list of your favorite types appears in three places in TrackRecord:

¢ When you choose File>New, your list of favorite types appears at the
top of the resulting submenu.

¢ When you use the New Item list on the Toolbar, your list of favorite
types appears at the top of the resulting list.

Chapter 2 ¢ Getting Started 31



Tip: Do not confuse
Favorite Data Types with
the Favorites menu, which
lets you save shortcuts to
frequently used views and
reports. For information
on the Favorites menu,
refer to “Identifying
Favorite Reports and
Home Pages” on page 31.

Where to Go Next

¢ When you use the Search Types list, your list of favorite types lets
you select a specific type to search.

Perform the following procedure to identify a data type as a favorite:
1 From the Tools menu, choose TrackRecord Options.

2 When the TrackRecord Options dialog box appeats, click the Favorite
Types tab. The Favorite Types tab (Figure 2-11) appears.

Figure 2-11. TrackRecord Options Dialog Box — Favorite Types Tab
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3 Identify the data types you want to appear in your Favorite Types list.

¢ To use the default list of favorite data types, select the Use the
types defined by the TrackRecord administrator option.

¢ To customize your favorite types list, select the Use these types
option. Select each data type you want in your list from the list
on the left, and click the Add > button. To remove an entry from
your list of favorite types, select its name in the list on the right
and click the <Remove button.

4  Specity the order for favorite types by dragging entries in the list on
the right up and down. The first entry in the Favorite Types list
appears as the label for New Item on the tool bar.

5 When you are finished, click OK.

You use TrackRecord to enter information about projects and to retrieve
and view that information. Although there are many tasks performed
with TrackRecord, the three primary tasks — entering, retrieving and
viewing data -- provide the framework for all other tasks. For a descrip-
tion of each of these tasks, consult the following chapters:
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¢ Chapter 3, “Entering and Editing Data”
¢ Chapter 4, “Retrieving Data”
¢ Chapter 5, “Viewing Data”
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Chapter 3

Entering and Editing Data

4 Using TrackRecord Forms
& Entering TrackRecord Data
¢ Changing Item Status

& Merging Items

Using TrackRecord Forms

For each type of information stored in the TrackRecord database —
Defects, Tasks, Team Members, and so on — you will want to store differ-
ent pieces of information. For example, you might want to store a name
and phone number for a Team Member and a summary and description
for a Defect. Each item type has its own data entry form, which is
composed of fields appropriate to that item type.

Figure 3-1. Tab Location on Defect Form
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To make data entry even easier, you can create item templates that store
default values for fields. Information about how to construct and use
templates is provided in Chapter 7, “Working With Templates”.

Although the Team Member form contains additional tabs, most Track-
Record forms include three tabs: Item, Links, and Change History.
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Item Tab

Tip: For additional
information on opening
an Item tab, see “Entering
TrackRecord Data” on
page 40.

Links Tab

To enter or change information, you open an item view, a form on which
you can enter or modify information about one item, such as one Defect
or one Person. Each type of item uses a different form, since each type
requires different information.

Item views use standard Windows controls, such as text fields, drop-
down lists, scrolling lists, check boxes, and radio buttons, to display and
update information about specific items. They also use some unique
controls, such as the Calendar and Add Item buttons.

The Item tab on a TrackRecord form (Figure 3-2) lets you enter informa-
tion about the item you are adding or updating. The fields displayed on
the item tab depend on the type of item with which you are working.

Figure 3-2. Item Tab for Task Item
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As you add information to the database, TrackRecord creates a network of
links between items. The Links tab (Figure 3-3) displays a list of all the
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Change History Tab

items in the TrackRecord database that refer to the item with which you
are currently working.

Figure 3-3. Links Tab allows you to navigate through your network of linked items by
selecting a link.
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The Change History tab (Figure 3-4) provides an audit trail of the changes
made to an item over time. When an item is created, modified, or
deleted, an entry is added to the change history list for that item. If a
person made several changes to an item during a single session, each
change will be noted separately.

Note: Forinformation about the WebServer’s change history window, refer
to the “Change History Button” on page 93.

Figure 3-4. Change History Tab in the Windows Client
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Expand Item Button

As you learned earlier, fields in one type of item can be links to other
items in the database. For example, in a Defect item the Project field
might be a link to an item of the Project type. The Project field’s drop-
down list would display a list of all Project items in the database, allow-
ing you to select an existing Project. The selected Project would then be
“linked” to this defect.

The Expand Item button lets you expand a link to another item. You can
display and update the fields belonging to that linked item. For example,
clicking the Expand Item button beside the Priority list in Figure 3-5
causes the window to display more fields for the selected Priority. If you
have appropriate privileges, you can add new items or modify the items
displayed. If you make changes, these changes will be reflected in all
other items that are linked to the changed item.

Figure 3-5. Using Expand Item Button
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Calendar Button
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The Calendar button (Figure 3-6) lets you specify dates from a graphical
calendar instead of entering a date with the keyboard. Click the Calendar
button to open the calendar and double-click a date to select the day you
want to enter.
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To choose a date on a past or future month, click the left (past) or right
(future) arrows at the top of the calendar. The single triangles move one
month at a time. The double triangles move one year at a time.

Figure 3-6. Using Calendar Button
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Add and Delete Item Buttons

The Add and Delete Item buttons (Figure 3-7) let you add and delete
items in the TrackRecord database in the course of maintaining other
types of items. For example, if you want to enter a new telephone
number while adding or editing a Person item, you would click the Add
Item button beside the Phone Number field, create the item you want,
and click Save and Close. (Note that the behavior of the button is config-
urable. Some fields display a list of existing items, allowing you to pick
one or to click New Item to create a new item of that type.)

City: State: zip: Country:

Clicking the
Add Item (+) Phone Mumbers: 7 ﬂ
button... =

|etS you Email Address:
. & Phone Number ltem - Bl E
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were updat-
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Figure 3-7. Using Add Item Button

To delete an item from one of these lists, select the item and click the X
button. Depending on how this field was defined when the type was
created, deleting an item from a list may remove it from the database.
You will be prompted to confirm the deletion. If the field was not defined
to allow deletion from the database with the X button, you can delete it
from the database by right-clicking on the item and choosing Delete
itemname from the shortcut menu.
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Expand Text Field Button

The Expand Text Field button (Figure 3-8) identifies resizeable text fields.
When you click the Expand Text Field button, the text field area expands
to the bottom of the window to let you display the complete text of an
extended description or note about an item. You can click the Collapse
Text Field button to collapse the text field to its original size.

Figure 3-8. Using Expand Text Button
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Clicking the Collapse Text button collapses the expanded field.

Entering TrackRecord Data
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1 From the File menu, open a new form using one of the following
methods:

¢ Click the drop-down arrow next to the New Defect button on the
Toolbar. If you or your Administrator has changed your Favorite
Types list, it may not be displayed. In this case, use the Toolbar’s
New Item drop-down list to select the appropriate form.

Open the Item Browser (see “Working With the Item Browser” on
page 25 for more information), right-click on a applicable item,
and select the New optionname from the shortcut menu (“Open-
ing New Project Using the Item Browser” on page 41).



Figure 3-9. Opening New Project Using the Item Browser

Item Browser

JJ | @ Advanced Search. ..

IS[=] E3

Types:

I~ show &l Items:

Assignrnent
Defect
DevPartner Reported Defect
Fault Reported Defect
QACenter Reported Defect
Feature
Task.
DevPartner Task
M5 Project Task
DevPartner Session
Person
Customer
Team Member

raiect L e
hare Grou M|
. Advanced Search...

Fault Manager

Fault Manager

QA Center Documentation
‘four Project

¢ Select the appropriate form from the File>New menu.

¢ Choose File>New>Other. When the Choose a Type dialog box
(Figure 3-10) appears, select the appropriate form and click the

New button.

Figure 3-10. Choose Type Dialog Box
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2 When the form appears, enter information in the appropriate fields.

Required: If you are using the WebServer, be sure to review “Notes about
the WebServer” on page 88 to avoid errors when opening your

Web page.

Note the following when entering defect data:

<& A single line text field can contain up to 255 characters.
¢ A multi-line text field can store up to 65,535 characters of infor-

maiton.

& A numeric field can store a number between 0 and

4,294,967,294.
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¢ The display format of a Date field is based on the regional settings
on the same client machine.

& Attempt to limit the amount of text to below 800 characters in
the Description field. If the characters exceed this amount the
partial display may appear as a garbage overlay of characters.

If your site has implemented templates, TrackRecord may fill in some
of the fields for you. Refer to Chapter 7, “Working With Templates”
for information on how to establish and use TrackRecord templates.

3 Ifyou are finished entering data, click Save and Close on the toolbar.
The drop-down menu next to the Save and Close button offers two
additional save options:

¢ If you want to add an unrelated item, choose Save and New from
the toolbar.

¢ If you want to duplicate the current information as part of a new
item, select Save and Duplicate.

Changing Item Status

42

From the time an item is opened to the time it is officially closed, it
typically undergoes a series of status changes; these changes are collec-
tively known as a workflow. For example, a new Defect typically starts
with a status of Unassigned. A project manager assigns the Defect to a
developer, updating its status to Assigned. If the developer confirms that
the problem exists and fixes the appropriate software, he or she would
move the Defect into a Pending Validation status, flagging it for testing
and verification.

A workflow defines the states an item goes through and the privileges
each user has to move an item from one state to another. Your Track-
Record administrator defines the workflow for items. For example, an
administrator might specify that a someone in Quality Assurance can
move a Defect with a status of Unresolved to a status of Needs More
Information or to Resolved.

Not all items follow a workflow. The Person type, for example, might
undergo a series of changes over time, but these changes do not consti-
tute a change in the status of the item. Your TrackRecord administrator
establishes which types of items will follow a workflow by placing a
Status field on the type form. The Person type does not follow a workflow
and does not contain a status field.
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To change the status of an item, follow these steps:

1 Open the appropriate item and enter any changes in the fields on the
form.

2 Use the Action button on the toolbar to select an action. You can
only select actions that your group is authorized to perform.

3 When you are finished, click Save and Close.

If you discover that your TrackRecord database includes duplicate items,
you can merge them to remove the redundant information. When you
merge one item, the source, into another, the target, TrackRecord replaces
all references to the source item with references to the target item
throughout the TrackRecord database, ensuring that database links are
preserved. When the merger is complete and the appropriate informa-
tion from the source item is moved to the target item, TrackRecord
deletes the source item.

If the two items you merge contain lists of information, such as
telephone numbers, the contents of the source item’s lists are added to
the corresponding list for the target.

Perform the following procedure to merge items:

1 Open the target item and the source item. You can open items from
the File menu, from the Item Browser, or from an Outline Report.

2 Click inside the dialog box of the target item to make it active.

3 From the Edit menu, choose Merge with Another Item. The Target
dialog box (Figure 3-11) appears displaying the type and name of the
item to which information will be transferred.

Figure 3-11. Target Dialog Box

Target =]

Target type: Defect
Target: 000010 Unfixed bug

Select an item in any window to
merge into the target.

4 Click inside the dialog box of the source item to make it active.

Click the Merge into Target button in the Target dialog box.
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If the source item has information in lists that can be transferred to
the target item, the Merge Items dialog box (Figure 3-12) appears.
Click Yes to transfer the item’s list contents.

Figure 3-12. Merge Items Dialog Box

Do you alzo want to merge the lists in <000011: TrackRecord buge with the coresponding lists in the target?

Mo | Cancel |

When the Merge Complete dialog box is displayed, click OK.

TrackRecord merges the two items, closes the dialog box for the
source item, and deletes the source item from the database.

7 Close the target item and the dialog box.
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Understanding Queries

Tip: If you are new to
TrackRecord and want to
create simple reports
quickly, you can use the
Header Wizard to display
data without creating a
query. See “Using the
Header Wizard” on

page 64.

To use information that has been entered into the TrackRecord database,
you must first identify the information in which you are interested and
create a query to retrieve that data. A query defines what is displayed. It
lets you formulate requests for specific data from the database.

Queries let you specify criteria for retrieving information in the Track-
Record database and are building blocks for Outline Reports. An Outline
Report consists of one or more queries that are formatted to display infor-
mation that is returned by queries. You select the type of item you want
to find and add parameters to make your query as specific (or general) as
necessary.
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Tip: For date fields, you
can use relative dates
(Today, 1 week from
today) to make reuse of
queries easier.

The query shown in Figure 4-1 returns all Defect items in which the
Current Build field is equal to 42.

Figure 4-1. Simple Query

@ Build Number 42 Defects - Query M= |
H@ Save and Close ‘ | Run Query Mow. . ‘ Options. . ‘
Query game: [ Build Number 42 Defects
Type: =)
List of types | [oefect I [
Fields In Defect
Bl Hotes =]
B Operating System
B Briority
. =l Project
List of search- Hspeciic Pojct
. B BuldsiReleases
able fields - Current Buld Numb
. . - Current Version 2
within the Descrption ail
Bl Documents
selected type Bl Functiondl Areas Find: | [allDefect icems =
B Keywords
[+ Milestones uwhere:| Defect, Assignment Project, Current is equal to j
- Mame il Humber
[l Requirements =
[ Sub-projects _ILI 47 5
« » Current Buld Number =
T add ko or modify this query,
rag a feld from the lst above | Return [the matching tems =
o the sunken area ta the
ight. Sort: | [1ione =

Drag a field from the list Search criteria to set specific
to use it in the query search parameters

When you create a query, you select:
¢ Type of item you want to find (Defect in the example)

¢ Fields you want the query to search on (Project and Build Number in
the example)

¢ Parameters to make your query as specific as necessary

You can create your own queries or use queries that have been
constructed for you by your TrackRecord Administrator.

Each selection criterion is represented graphically as an arrow. Including
more than one arrow in a query allows you to filter database information
using several fields as selection criteria. The output from one arrow

becomes the input set for the next arrow, until the end of the query
chain is reached.

Composing Queries- Guidelines to Follow
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While TrackRecord provides great flexibility in the creation of queries,

you should follow a few simple rules to ensure that your queries perform
satisfactorily.

¢ Begin your query with the type of item you want to find. For exam-
ple, if you want to find all the Defects for a particular Project, start by



selecting the Defects data type, then add a query element for the
Project field. If you start your query by asking for all Project items,
the query would check all Projects, rather than Defects that relate to
a given Project.

To create an AND specification (Figure 4-2), place related queries side-
by-side; to create an OR specification (Figure 4-3), place queries top-
to-bottom.

Note: Using the OR statement within a query will nullify the desired results

Query Execution Order

if the types are the same, such as status or priority.

Figure 4-2. An AND Specification for Search Criterion

Query will search for defects relating to
P EC ey Fault Manager AND were entered by the
current user. Iltems that meet both crite-
ria will be selected.

efect,, Project =
ault Manager

Figure 4-3. An OR Specification for Search Criterion

Defect.. Project = Query will search for defects relating to Fault
Fault Manager
—I/ Manager OR defects entered by the current user.

Items that meet either condition (as well as other
[iefect,, Entered by . .
elements in the query) will be selected.

Create many simple queries. You can later combine these queries into
more complex data extraction operations by creating Outline Reports
and attaching simple queries. (Refer to “Using Outline Reports” on
page 55 for more information.)

Avoid complex queries and queries that return very large data sets.

In a sequence of query elements (arrows), start with the query ele-
ments you expect to return the fewest items.

The fastest queries are often the ones that run on the entire database.

To create a query based on a specific date, do not use the GUI date
selector. Simply type in the date in the date field.

TrackRecord executes queries from left to right, then top to bottom
following the arrows in the queries.

Example One

In the example shown in Figure 4-4, the query would be executed in the
following manner:
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1 The database will search for defects related to Your Project.
2 The database will search for Critical defects relating to Your Project.

3 The database will search for High priority defects relating to Your
Project.

4 The results of step 1-3 are combined and can be displayed with the
Run Query Now button.

Figure 4-4. Example One

Defect. ., Priority _J—AI'I'OW B
Crltlcal

Arrows (A and B)
or (A and C)

Defect.. Project =

‘four Project
efect. .. Priority Arrow C
High

Arrow A

Example Two

In the example shown in Figure 4-5, the query will retrieve data in the
following order:

1 The database will search for items assigned to <CurrentUser> AND are
assigned a priority of Critical.

2 The database will search for items assigned to Matt Johnson AND are
assigned a High priority.

3 The results of step 1-2 are combined and can be displayed with the
Run Query Now button.

Figure 4-5. Example Two

Arrow A

Arrows (A and B) Defect. .. Assigned to

Defect.. Priofiby =1 Arrow

or (C and D) = <Current User = / - Critical / B
Defect. .. Assigned to efect,, Priority =2
= Johnson, Matt / FHigh Arrow
[ D

Arrow C

Example Three

In the example shown in Figure 4-6, the query will execute in the follow-
ing order:
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1 The database will search for items with a Critical OR High priority.

2 The database will search for items assigned to <Current User> AND a
Critical OR High priority.

3 The database will search for items assigned to Matt Johnson AND a
Critical OR High priority.

4 The results of step 1-3 are combined and can be displayed with the
Run Query Now button.

Figure 4-6. Example Three

Arrow AB

Arrows ((A or B)

and C) or ((A or B) g
Defect. . Priority =2
- High

Defect,, Assignedt——————— Arrow C

Defect, . dssignedfa Arrow D

= Johnson, Matt /

Creating a Query

To create a query, perform the following procedure:
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T On the toolbar, choose Query from the New Item drop-down list.
Alternatively, you can open a new Query from the File menu. Choose
New>Query (Figure 4-7).

Figure 4-7. Query Form

Run Query Create Outline Report Options button
Now button button
@ George - Query
ﬂ@gave and Close ‘ ‘ Run Query Naw... ‘ Optiarg.. |
Query name Query nme: [ Gaaree
T |. Type: d
fect - E fect.. Project =
ype li st Defec =] perect. Proe:
Eields in Defect
Query area Fem=mer—— =
Date Entered
Description
[+ Duplicate Defects
[ Entered by
[ Fix by Milastane
Field list | - Funcional reas
IdentFier _';I
[ Keywords | E
[ Notes
(- Oparating Systam Find:  [al Defect irems =
[ Priarity
- Project where: Defect. Assignment Projsct s equal t =
. . (- Related Requirements |
Search criteria Tepartad by n
. [ Resolution =
fields Resolition Detals | [ tiones Bl =l
To add to or modify this query,
draq a figld From the list aboe: Return: |the mmatching items j
0 the sunken area to the
ight. Sorti  [nione =
Sort options Find list

2 Enter a name for this query in the Query Name field. Query names
can contain up to 39 characters.

3 From the Type drop-down list, select the type of item you would like
to find. For example, if you want to find all Defects in the Track-
Record database relating to a specific development project, you
would choose Defect.

4 In the Field drop-down list, select a primary search criterion and drag
it to the Query area (Figure 4-7). For example, to find the Defects
relating to a specific project, drag Project to the Query area. An arrow
identifying the search field (the query element) will appear in the
Query area.

5 Use the Find drop-down list to specify whether child types should be
retrieved.

Normally, if you query a parent type such as Defect, the results
include child types, such as Unassigned Defect. If you want to
exclude child types from the query results, select Excluding child
types. Refer to “Understanding Data Type Inheritance” on page 17
for additional information on parent-child relationships.
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Tip: When using multiple
query elements, the
search criteria fields will
reflect the currently
selected element. See
“Composing Queries-
Guidelines to Follow” on
page 46. for information
on structuring queries.

6 Specify search criteria.

<

Use the Where drop-down list to specify the search criteria you
want the query to use. For example, to find Defects associated
with the Colossus project you would select Is Equal To and then
enter Colossus in the field below. As you specify selection crite-
ria, TrackRecord updates the text in the query element (the
arrow).

In the Return drop-down list, specify what you want TrackRecord
to do when it finds an item that matches the search criteria. Typ-
ically, you want the query to return all items that meet the search
criteria you have entered. Alternatively, you can retrieve all items
that link to anything meeting your search criteria.

Optionally, use the Sort drop-down list to specify how the query

should sort the items it retrieves.

— If you choose Ascending, TrackRecord sorts the selected
items by the selection field you specified in alphabetical order
1,2, 3,..%Y, 2).

— If you choose Descending, TrackRecord sorts the selected
items by the selection field you specified in reverse
alphabetical order (z, v, x,...3, 2, 1).

— If you choose None, TrackRecord does not sort the selected
items.

Repeat step 3-6 to add additional query elements.

7 If you want to share this query with other users or be notified when
new items meet the selection criteria, click the Options button to dis-
play the Query Options dialog box (Figure 4-8).

Figure 4-8. Query Options Dialog Box

Query Options x|

Qwner: IAdmin VI
Skatus: I Mot Shared sharing. .. |

™ Email me when new items match this query

Ok | Cancel |

<&

<&

To share the query with other users, click the Sharing button.
When the Sharing dialog box appears, click the Share To button
and select the share groups with whom you want to share the
query. If you choose Not Shared, no one other than you can use
the query.

To receive notification through electronic mail when a new item
meets the selection criteria for this query, select the Email Me
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check box. Note that your TrackRecord administrator must con-
figure AutoAlert and record your electronic mail address as part of
your user profile for this feature to take effect.

Note: If you choose to share a query and also click the Email Me check

8
9
Tip: Outline Reports are
described in “Using
Outline Reports” on page
55.

10

box, the email will only be sent to you, not to members of Share
Groups.

¢ Click OK to close the Sharing dialog box.

Optionally, click the Run Query Now button on the toolbar.

Running the query from within the Query dialog box allows you to
test your query. A search results dialog box will display all items from
the database that match your query. If the results do not match your
expectations, modify the query.

Optionally, click the Create Outline Report button in the toolbar.

Since queries are most often used to create Outline Reports, this
button provides a shortcut to that feature.

The new query is automatically saved and entered as a header in a
new Outline Report. (This option is not available on Queries created
from within Outline Reports.)

Save the new query by clicking Save and Close or by choosing
File>Save.

Opening, Modifying, and Deleting Queries
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TrackRecord makes it simple to open, modify, and delete queries.

Opening and Modifying Queries

To open and/or modify an existing query, perform the following steps:

1
2

From the File menu, choose Open>Query.

After making modifications, click the Save and Close button.

Deleting Queries

To delete a query, perform the following steps:

1
2
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From the File menu, choose Manage.

From the displayed list, select the type of query to be deleted. The
Manage dialog box appears.

Select the query to be deleted and click the Delete button.



Chapter 5
Viewing Data

4 Understanding Views

¢ Opening, Modifying, and Deleting Views
4 Using Outline Reports

& Working with Graphs

4 Using the Milestone Status View

& Utilizing the Calendar View

Understanding Views

After you identify the information in which you are interested by creat-
ing a query, you must determine what format in which you want the
information displayed. A view defines how data is displayed. Track-
Record’s four types of views present information in an organized, easy-to-
use way and contain the most current information in the database:

¢ Outline Reports— Dynamic reports that allow you to view summa-
ries of the TrackRecord data returned by a query or set of queries,
select what fields appear in columns in the report, and change the
order in which the columns and headers are displayed. For more
information, refer to “Using Outline Reports” on page 55.

¢ Graphs— Displays a graphical summary of the information in an
outline report. Depending upon the type of information, you can
generate pie charts, bar graphs, trend graphs, and more. For more
information, refer to “Working with Graphs” on page 70.

¢ Milestone Status— Provides a provides a concise summary of project
status that captures a broad range of project status indicators, from
code base volatility to how much automated error detection has been
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performed. See “Using the Milestone Status View” on page 74 for
additional information.

¢ Calendars— TrackRecord automatically categorizes and displays a
simple list of your appointments and tasks or a tick-marked schedule
of each day. You can maintain and display multiple calendars simul-
taneously. Refer to “Utilizing the Calendar View” on page 81 for
more information.

Opening, Modifying, and Deleting Views
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TrackRecord makes it simple to open, modify, and delete views.

Opening and Modifying Views

There are several ways to open an existing views: the Open button on the
Toolbar, File>Manage, or File>Open, which is the method used in the
following steps.

To open and/or modify an existing view, perform the following steps:
1 From the File menu, choose Open.
2 From the displayed list, select the type of view to be opened.

3 After making modifications, click the Save and Close button.

Deleting Views

To delete a view, follow these steps:
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1 From the File menu, choose Manage.

2 From the displayed list, select the type of view to be managed. The
Manage Outline Reports dialog box (Figure 5-1) appears.

Figure 5-1. Manage Outline Reports Dialog Box

Manage Outline Reports E

Show: IAII CQutline Reports j
Mame | Cwner | Status | Qpen I
All Projects <Admin = Shared
Bugs <Admin Shared Delete |
Defect Status Report <Admin = Shared ;
Defects Assigned to Me <Admin Shared Duplicate. .. |
DevPartner/QACenter Reported Defects  <Adminz Shared
Fault Manager Reported Incidents <Admin = Shared Rename. .. |
Priorities 1 or 2 <Admin = Mok shared
Recent Activity <Admin = Shared
Tasks Due This Week <Admin = Shared

Description:

I o) Close | Help

3 Select the view to be deleted and click the Delete button.

Using Outline Reports

Outline Reports (Figure 5-2) let you selectively retrieve information from
the TrackRecord database through dynamic reports that select, sort, and
format summaries. When you create an Outline Report, you insert
headers into the report and associate a query with each header. Queries
are building blocks for Outline Reports. When you run the report, the
queries are run and the matching information is displayed in columns in
the report.
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Tip: If you are new to
TrackRecord and want to
create simple reports
quickly, you can use the
Header Wizard to display
data without creating a
query. See “Using the
Header Wizard” on page
64.

Tip: You can specify what
data is to be displayed in
the columns of the report,
rearrange the columns,
and rearrange the
headers in the report.

Tip: The TrackRecord
sample database provides
several Outline Reports
that demonstrate the use
of headers and queries.
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While you are viewing an Outline Report, TrackRecord periodically runs
the queries associated with the report to ensure the contents of the report
reflect the most current information in the database.

Figure 5-2. Sample Outline Report

B Priorities 1 or 2 =] 3
Parent headers [E=1= || omtens.. | 150 0eie |
° =

with queries —~——_]

attached

Columns (fields from
the items found by
the query attached
to this header)

[~ Your Project

on Save
+000016: Unfixed
bug

Priorities 1 Summary Assigned to
+000014; iles ACK,
iy corrupted
+000015: Crashes Crashes on Save KMD,

Unfixed bug ACK,

1% Your Project Priorities 2 (2 items)

Sibling of Your
Project Priorities 1;
Child of Your
Project Priorities 1
or2 e

KN H
Outline Reports are not outlines in the tradition sense; you cannot use an
Outline Report to enter data in a hierarchical format. Rather, Outline
Reports are a mechanism for generating a dynamic report by querying
the database. The queries associated with the Outline Report act like
smart filters, letting through only the applicable data, and presenting
that data in an outline-like format.

The headers on an Outline Report are hierarchical. A child header can
display only data that meets the Query conditions of all of its parent
headers. Refer to “Using Headers in Outline Reports” on page 63 for more
information.

To collapse or expand a header, click the bullet to the left of the header’s
title. When a header is expanded to show its child headers and data
items, its bullet appears as a white circle with a minus (-) sign inside it.
When a header is collapsed, concealing its child headers and contents, its
bullet appears as a black circle with a plus (+) sign inside and the number
of items it contains appears to the right of the header text. You can use
this feature to create numeric summary reports that identify data catego-
ries and item counts within each category.

When you view a list of existing Outline Reports, the list shows both
your privately owned reports plus all other Outline Reports you are
permitted to share.
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Creating a New Outline Report

There are five steps to creating an outline report:

¢ Defining Queries

Adding Report Headers
Configuring New Items Options
Setting Report Columns
Specifying Print Options

L K R R 4

Defining Queries

If the queries you want to use in your Outline Report do not already
exist, you should create them before you establish the Outline Report.
Alternatively, you can create them as you add report headers. Refer to
Chapter 4, “Retrieving Data” for information on setting up queries.

Adding Report Headers
1 From the File menu, choose New>Outline Report. An untitled Out-
line Report (Figure 5-3) appears.
Figure 5-3. Blank Outline Report Form
E Untitled3 M [=] B3

H £ | 8= tnsert Header = < | 41| Options... | 1570 e |

This Outline does not yet contain any headers. To insert one, use Insert Header. =l

I — 1z
2 (Click the Insert Header button and select the As a Sibling Header
option. The Header Properties dialog box (Figure 5-4) appears.
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Tip: If you are new to Figure 5-4. Header Properties Dialog Box
TrackRecord or have not

created queries to be used
in this report, you may General | Hew Ttems | Columns | Print Options |
prefer to use the Header
Wizard. This option is

Show:  [all Queries =
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H in H Assignments: Al <Adminz= Shared
descrlbed n USIﬂg the Assignments: Assigned to me <Adminz= Shared
H ” Assignments: Entered Today =Adminz Shared
Header Wizard” on page esanmenta: Entored withi st ... <adming shared
6 4 Assignments: Entered within past week  <admin> Shared _lj
. 4] W

his query wil not find any ltems. The Remainder query only works when the
urrent header has a parent.,
Hearer text:
& Use the query name
 Use: | Remainder

ok | caneedl | web |

3 On the General tab, select the query you want for your top-level
header or click the New button to create a new query.

To review the contents of an existing query, click the Open button.

If you create a new query and use the Run Query Now button, note
that the query results will not reflect the filters of the parent headers.

4 Click a Header Text option to use the query name or to enter more
descriptive text for the header.

5 Click OK or click another tab to continue setting up the header.

Configuring New Items Options

The options on the New Items tab are used to define custom behavior
when a user right-clicks on a displayed header. It adds a New Item option
to a header’s right-click menu and allows you to specify a template to be
used for new items. If you are new to creating Outline Reports, you do
not have to enter anything on this tab.

1 Right-click in the Outline Report and select Set Template.

2  On the New Items tab, select the type of item to be added.

3 Select a template to be used when items are added. To learn about
templates, refer to “Working With Templates” on page 101. Click OK
or click another tab to continue setting up the header.

Setting Report Columns

Use the Column tab to specify what columns are to be displayed for this
header.
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1 Right-click in the Outline Report and select Set Columns to display
the Columns tab (Figure 5-5) on the Header Properties dialog box.

Figure 5-5. Columns Tab in Header Properties Dialog Box

Header Properties =]
General | Hew Ttems Columns | erint Options | Add
/
© Shaw the same colamns as the parent header 1 button
Types G B thiss colire:]
. Type:
| ISt ——| Defect hd
Fields in Defect fiins to be displayed: Columns to
Assigned to = Add = Default abbreviation: .
aachmerts > | be Displayed
Remove ik 4 <gemove .
BuidjRelease Found list
button Corfiguration
Date Entered o =l
Description
e ot e [ = Column
Entered by Show as: Default abbreviation: T name field
Fix: by Miestone
Functional Areas Width: ' fs wide as possible
Identer =l  Exatly [ 05 | inches Show As
list

ok | canced | heb

Column width setting

2 Select one of the following options for column display:

¢ Show the Same Columns as the Parent Header—Displays the
same columns as are displayed under the parent header.

¢ Show These Columns— Allows you to customize the column
display for the selected header.

3 Select the type of data in the header from the Type drop-down list.

4 Select a field you want to display in the Outline Report and click the
Add> button to move the field name into the Columns To Be Dis-
played list.

The Default Abbreviation is always displayed. It is established by your
Administrator and cannot be eliminated from the report. To display
multiple lines in the description field, select Descriptions and then
Full Notepad from the Show As drop-down list. Repeat this step for
all columns to be displayed.

5 Specity the order in which you want columns displayed by dragging
field names up and down within the Columns To Be Displayed list.
For example, if you want Project to be displayed in the first column,
drag it to the top of the list.

¢ Use the Column Name field to change the label the Outline
Report displays at the top of the column.

¢ Use the Show As drop-down list to specifty how you want the col-
umn displayed.
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Tip: When you print an
Outline Report,
TrackRecord prints items
within open headers. If
you collapse a header, the
items under that header
will not be printed.

¢ The available options vary depending on the field type. For a
Name field, for example, you could choose to display the full

name, initials, name and address, and so on.

<& Specify how wide you want the selected column to be within the

Outline Report.

If you want TrackRecord to determine how much space to

use, select the As wide as possible option.

If you want the column to be a specific width within the

report, select the Exactly option and enter the number of
inches for the column width in the Inches text box.

6 When you have finished adding and formatting columns for the
header, click OK or click another tab.

Specifying Print Options

You can specify print options for an Outline Report to override your
default print option settings, and you can specify print options for

specific headers within the report.

¢ To set print options for the whole report, click the Options button on
the Outline Report toolbar and select the Print Options tab (Figure 5-

6).

¢ To set print options for individual headers, right-click on the header,
choose Properties, and select the Print Options tab.

The following steps are common to both report and individual header

print options.

Figure 5-6. Print Options for Individual Header

Header Properties
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(=] [without Following line =]
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™ start this header on a new page

space
[o3 I

cencel |

Help

Change Font
buttons

Print list

Item styles list

1 Select the typeface and size you want to use to print report headers
and data items by clicking the Change Font button. When the Font
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Tip: For additional
information on printing
Outline Reports, see
“Printing from Outline
Reports” on page 69.

dialog box appears, select the typeface, style, and size you want to
use. When you are finished, click OK.

Required: Headers and items must use the same type size, even if they use

different typefaces.

From the Print drop-down list, select Headers and Items or Headers
Only to print the items belonging to report headers.

If you are printing data items, use the Item Style drop-down list to
select the lead-in character for item entries.

¢ Select the Leading Bullet option if you want each item to be pre-
ceded with a bullet (e).

¢ Select the Leading Number option if you want each item to be
preceded with a sequence number. Sequence numbers restart
within each header.

¢ Select the Leading check box option if you want each item to be
preceded with an empty check box. Check boxes simplify track-
ing which items within a list have been discussed or completed.

Select whether to print with or without a line following each item.
Use the Header Style drop-down list to specify how you want head-
ers on the report printed.

¢ Select Header Text Only or Header Text and Item Count.

¢ Select whether to print with or without a line following each
header.

In the Space After Each Item and Space After Each Header fields,
type a number to specify how much vertical space you want between
lines.

If you are setting print options for an individual header, choose
whether to start this header on a new page and, if this is a child
header, whether to use the parent headers print options.

When you are finished, click OK. The changes will not be reflected
on your screen display; they are used only when reports are printed.

Customizing Outline Reports

The Outline Reports tab on the TrackRecord Options dialog box controls
the default typeface and size for new Outline Reports and what headers
in a report do when you double-click them. You can override these
default settings for specific reports or for specific headers within a report.
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If you are new to TrackRecord, read “Using Outline Reports” on page 55
before customizing the Reports.

1
2
3
Tip: You can use different
typefaces and styles for
headers and items, but
the header font and the
item font must use the 4
same type size. Resetting
the size for one
automatically changes
the size for the other.
5
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From the Tools menu, choose TrackRecord Options.

When the TrackRecord Options dialog box appears, click the Outline
Reports tab. The Outline Reports dialog box (Figure 5-7) appears.

Figure 5-7. TrackRecord Options Dialog Box — Outline Reports Tab
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To change the font used to display report headers or items in an Out-
line Report:

¢ Click the Change Font button.

¢ When the Font dialog box appears, select the typeface, type style,
and size you want TrackRecord items to use.

In the Header Handling drop-down list, specify what you want
TrackRecord to do when you double-click an Outline Report header.

¢ Select Expand and collapse section if you want TrackRecord to
display and hide the entries under a header when you double-
click it.

¢ Select Open Header Properties if you want TrackRecord to dis-
play the property form for a header when you double-click it.

¢ Select Open Query if you want TrackRecord to display the query
associated with a header when you double-click it.

Click OK.



Using Headers in Outline Reports

Tip: If you are new to
TrackRecord or have not
created queries to be used
in this report, you may
prefer to use the Header
Wizard. This option is
described in “Using the
Header Wizard” on page
64.

Tip: For information on
Parent, Child, and Sibling
relationships, refer to
“Understanding Data
Type Inheritance” on
page 17.

Headers are the building blocks of Outline Reports. They are used to
isolate and filter project data by associating database queries with
Outline Reports. Headers have properties that you can modify such as
data view options, use of templates, column content and format, and
print and displaying fonts.

Creating a Report Header

For information on adding a report header to an Outline Report, refer to
“Adding Report Headers” on page 57.

Adding Multiple Headers

To add more headers to your reports, select a header in the report and
click the Insert Header button.

¢ To add headers at the same level as the one you selected, choose
Insert Header>As a Sibling Header.

¢ To add child headers, choose Insert Header>As a Child Header.
Child headers act to further segment the data selected by the parent
header. The selection criterion of the parent header limits the data
available for selection by the child header.

Dragging Headers in an Outline Report

You can easily rearrange your Outline Report by dragging headers from
one location to another within the report. When the cursor is over an
area where the header can be dropped, the dragged image will snap in,
showing you where the dropped header will appear. You can drag one
header above or below another as a sibling, which puts them at the same
level within the report. You can also drag one header below another to
position it as a child or drag one header above another to make the
dropped header a parent header.

If it is not possible to drop a header at a given location, the header will
not snap in at that location, or will snap to the closest alternative.

Employing the Remainder Header

TrackRecord includes a special header called Remainder, which acts as a
None of the Above summary item. When you include a Remainder header
as a child header, it gathers and summarizes all the items belonging to
the parent header that have not been listed in the child headers above it.
The Remainder header is typically used to identify items belonging to a
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parent header that fail to match all criteria pertaining to sections under
that parent header.

By moving the Remainder header within a parent header, you can
summarize the none of the above items quickly and easily. Figure 5-8
illustrates how you can move the Remainder header from one location to
another within an Outline Report to obtain different summaries.

Figure 5-8. Using Remainder Header
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The first screen summarizes all defects, sorted by status, with the number
of defects of each status shown in parentheses beside the sibling header.
The Remainder header indicates that the product has 19 defects whose
status is not Open or Fixed.

When the Remainder header is moved above the Fixed Defects header in
the second screen, the item count for Remainder changes from 19 to 28.
The Remainder header is now counting the Open Defects it was counting
before (19), plus the Fixed Defects (9). Similarly, when the Remainder
header is moved above the Open Defects header, the item count for
Remainder changes to 30, representing the number of items of Open
Defects (2) in addition to the number of items of Fixed Defects (9), and
the number of items it represented in the first screen (19).

Using the Header Wizard

The Header Wizard is a TrackRecord utility that simplifies the creation of
Outline Reports. The Header Wizard is most useful in two situations:

¢ When you are a new TrackRecord user unfamiliar with creating que-
ries and inserting headers

¢ When you want to create Outline Reports that would require multi-
ple, repetitious queries

For example, to create a report listing tasks assigned to certain Team
Members, you would have to create a query element for each person
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Tip: Click Back to back
up one step. Click Next to
move to the next step.

(AssignedTo=Bob, AssignedTo=Mary, AssignedTo=]Joe, etc.). To group
the tasks under separate headers would be even more tedious, since

you would have to create separate queries. With the Header Wizard,
you could identify all Team Members at one time by selecting them

from a list and specifying how you want the tasks grouped.

To use the Header Wizard, follow these steps:

1
2

From the File menu, choose New>Outline Report.
Choose the Insert Header>Using Header Wizard. The Introduction
dialog box (Figure 5-9) appears.

Figure 5-9. Header Wizard Introduction Dialog Box
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Read the instructions on the Introduction dialog box. If you want to
skip this dialog box when you run the Header Wizard in the future,
select the Don’t Show This Introductory Screen check box. When
you are finished, click the Next button.

In the Select Item Types dialog box (Figure 5-10), select the check box
corresponding to each type of item you want to retrieve from the
TrackRecord database.

Figure 5-10. Select Item Types Dialog Box
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The Header Preview pane displays the name of each type you select.
When you are finished, click Next.

In the Choose Field to Query On dialog box (Figure 5-11), specify the
option you want to use as your query criterion.

Figure 5-11. Choose Field to Query On Dialog Box
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Click on one of the following options:

<&

Find All Items— Searches for all items. Click Next and skip to

Query On Field Named— Finds items that have a specified value
in a field. Select the field you want to use. For example, if you
want to look for Defects associated with a specific project, you
would choose Project as the query field. If you choose more than
one type in step 3, the option may not be available. Click Next
and continue to step 5.

If you selected a query field in step 4, use the Choose Specific Values
To Find dialog box (Figure 5-12) to specify the values you want the
query to find.

Figure 5-12. Choose Specific Values to Find Dialog Box
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If you want the query to search for more than one value, click each
value you want. For example, if you want to look for Defects associ-
ated with three specific projects, you would click each project name.
To deselect an entry, click it again. When you are finished, click Next.

In the Grouping dialog box (Figure 5-13), specify how you want the
query results to be grouped by selecting the associated option.

Figure 5-13. Grouping Dialog Box
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<& To group selected items under separate headers, select the Group
Them Under Multiple Headers option. Click Next and continue
to step 7.

¢ To group selected items under one header, select the Put Them
All Under a Single Header option. Click Next and skip to step 8.

If you specified in step 6 that you wanted selected items grouped
under multiple headers, use the Grouping Options dialog box (Figure
5-14) to specify how TrackRecord should group items.

Figure 5-14. Grouping Options Dialog Box
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The following options are available:

¢ Group by Type— Places all items of the same type together, but
do not sort them.
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Group by Value—Places all items with the same value together,
but do not sort them.

Group by Type, Then By Value— Places all items of the same
type together and sort them by value.

Group by Value, Then By Type— Places all items with the same
value together and sort them by type.

When you are finished, click Next.

In the Placement Options dialog box (Figure 5-15), specify where the
new headers should appear on the Outline Report.

Figure 5-15. Placement Options Dialog Box
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If new headers should appear at the same level as the current
header, or if these are the only headers in the report, select the
Insert as a Sibling option.

If new headers should appear as subheaders within the current
header, select the Insert as a Child option.

When you are finished, click Finish. TrackRecord formats the Outline
Report with the new headers, retrieves the items that meet the header
search criteria, and displays the selected items under the appropriate
headers.

You can use the Header Wizard to insert as many headers as desired in
your report.

Opening Items in an Outline Report

68

Each item entry in an Outline Report represents an item in the Track-
Record database. To open an item, double-click its entry in an Outline
Report. If you want to update the information displayed for the item,
make the appropriate changes and close the form; click Yes to save your
changes.
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Creating New Items from an Outline Report

You can create new items from within an Outline Report. Refer to
“Configuring New Items Options” on page 58 for information about
establishing the type of items that will be created and the template to be
used. To create a new item from within an Outline Report, perform the
following steps:

1 Select the header under which the item will be created.

2 Right-click and select the New itemtype option. The item type is the
default type of item included in this header. An item form appears,
allowing you to create a new item.

Utilizing the Shortcut (Right-Click) Menu

When you are working in an Outline Report, you can use the shortcut
menu to perform a variety of functions. To open the shortcut menu,
right-click an outline header or item.

As Figure 5-16 illustrates, the contents of the shortcut menu change
according to the type of header or item you right-click.

Figure 5-16. Shortcut Menus for Headers and Items
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Printing from Outline Reports

There are three methods available to print multiple defects in an outline
view:

For information on specifying print options for an Outline Report to
override your default print option settings, and you can specify print
options for specific headers within the report.
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Tip: When you print an
Outline Report,
TrackRecord prints items
within open headers. If
you collapse a header, the
items under that header
will not be printed.

¢ Hold the keyboard’s Shift key while right-clicking a defect. An option
will appear on the menu allowing you to print the defect and the rest
of the set.

¢ Hold the keyboard’s Control key (Ctrl) while right-clicking a defect.
This allows you to print that defect as well as the next 15. Please note
that this command will create a separate print job for each defect and
will create 15 print jobs with one defect each.

¢ Hold the keyboard’s Control key (Ctrl) + C to copy the result of the
header. Open an application you will be displaying the report in (e.g.
Microsoft Word) and use the Ctrl + V keystrokes. Multiple header
results can be displayed on a single document using this method.

To create printed copy that looks like the screen format of Outline
Reports:

1 Hold down the keyboard’s Shift key, right click on the first item
under a header in your Outline Report.

2 Select Print from the menu. This command will print out all of the
items in the list until the next parent header is reached. Repeat the
process if desired.

Working with Graphs

Tip: Reports with
symmetric, hierarchical
headers produce the most
meaningful graphs.

The Graph view displays a visual summary of the information in an
Outline Report. Graphs can be used to effectively:

¢ Convey information quickly
¢ Identify trends which may not be apparent

¢ Display relationships that may exist between groups or series of num-
bers
Note: Graph availability is governed by the number of parameters in the
query that resides in the header.
After a graph is generated, TrackRecord updates it automatically when its
underlying data changes. However, the graph does not change if you
modify the Outline Report view from which the graph was generated.

You can print and save Graph views just as you do any other view. You
can copy graphs generated by TrackRecord into graphics applications,
such as Microsoft Paint, or into text editors, spreadsheet programs, and
electronic mail applications that can accept bitmap images, such as
Microsoft Word, Microsoft Excel, or Microsoft Outlook. For more infor-
mation, refer to “Integrating TrackRecord with Other Applications” on
page 111.
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Types of Graphs

Tip: The graph style
toolbar buttons become
active when the style is
appropriate for the data
being graphed. Pie graphs
require two or more
parameters.

Tip: The graph style
toolbar buttons become
active when the style is
appropriate for the data
being graphed. Bar
graphs require two or
more parameters.

Depending on the information in the Outline Report, you can generate
the following graphs: pie, bar, stacked bar, and trend (line and area).

Pie Graphs

A pie graph (Figure 5-17) is a pictorial summary that displays the number
of items matching a particular set of queries in an Outline Report. The
results of each query represent a single pie slice (percentage) on the
graph. They are useful in seeing the percentage relationship between
components. Show the change in component proportion at different
times using two pie graphs.

Figure 5-17. Pie Graph— Defects by Team Member and Priority
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Bar Graphs

A bar graph (Figure 5-18) is a pictorial summary that displays the number
of items matching a particular set of queries in an Outline Report. The
results of each query represent a single bar on the graph. A bar graph is
useful when comparing the magnitude of, or differences between items.

Figure 5-18. Bar Graph— Defects by Status and Priority
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Tip: The graph style
toolbar buttons become
active when the style is
appropriate for the data
being graphed. Stacked
bar graphs require three
or more parameters.

Tip: The graph style
toolbar buttons become
active when the style is
appropriate for the data
being graphed. Trend
graphs require two or
more parameters, one of
which must be time-
related.

Stacked Bar Graphs

A stacked bar graph (Figure 5-19) displays the results of queries, which
are used to calculate all the bars on the graph. Each point is the number
of items matching a particular value for a field in that query. A stacked
bar graph shows bars on top of one another to convey relative propor-
tions of parts to the whole, and to each other. Data is presented in
segments and bars.

Figure 5-19. Stacked Bar Graph— Defects by Team Member and Priority for the Bolts
‘N Things Application
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Trend Graphs

A trend graph is used to show rates of change over time, especially if data
quantities differ greatly. It is useful for comparing two series of data if
large quantities are involved, or when quantities differ greatly between
two series. There are two types of trend graphs in TrackRecord (Figure 5-
20):

¢ Line graphs — Used to show trends in data over equally spaced
intervals of time. It is useful for a long series of data, or comparison
of two or more series of data.

¢ Area graphs — Used to show trends in data over time. It is useful for
emphasizing the magnitude of changes of time. An area graph is the
equivalent of a stacked bar graph, for continuous data.
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Trend graphs use the results of a single query to calculate all the points/
bars/slices on the graph, and each point is the number of items matching
a particular value for a field in that query.

Figure 5-20. Example of a Line and Area Graph
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Creating Graphs From Outline Reports

To create a graph from an Outline Report, select the appropriate header
in the report and click the Graph button on the toolbar (Figure 5-21).

Alternatively, right-click the appropriate header and choose Graph from
the shortcut menu.
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Formatting Graphs

If the information in the header is not appropriate for graphing, the
Graph button and option will not be active.

Figure 5-21. Creating Graph from Outline Report

Selecta [HEE =[]
header H @‘ 9 Insert Headsr = \| ;]|| Dptlnns”.l {5 s Dzt ‘
—te i =
H © Unfized bugs Newtem.
Inan O Priority 1 Summary HNew Defect Ins
Outline +000017: Unfized bugs Unfixed bugs Open Query Enter
+000010: Unfixed bug Unfixed bug il EL =)
Report +000014: Data files chrrupted Data files corrupted Delete Duery Del
e +000015: Crashes gh Save Crashes on Save
~000016: Unfixed bug Unfixed bug Change Quey.
then © Priority 2 (7 itenfs) Set Templates
e © Remainder {0 itéms) Set Colurans.
1 Fixed (7 items) Set Header "New [tem' Tupe
CIICk the Run Header Wizard
Gra ph — Graph
IErge T iuetayerage Sessians.
button...
Cut Crls
.. or Copy Ciike
Baste il
choose Delete Header. Del
Gra ph Propetiies...
from the 5
Al 3
shortcut 4
menu.

TrackRecord automatically selects a graph style based on the structure of
the Outline Report and the contents of the queries in the outline. You
can override the default graph style by choosing a different graph icon
from the Graph toolbar. The graph style toolbar buttons become active
when the style is appropriate for the data being graphed.

¢ To select a different graph style, click a graph style button on the
Graph toolbar or choose a graph style entry from the View menu.

¢ For line graphs, you can add a line identifying the overall trend by
choosing View>Best Line Fit. Similarly, you can insert vertical bars
connecting graph points to the baseline by choosing View>Draw
Bars to Points.

¢ To choose whether to display a legend for your graph, choose View
>Legend.

Using the Milestone Status View

When project plans are developed, typically the project is broken into
manageable segments or development cycles, target dates are identified,
and criterion for each milestone is defined. Once development is under-
way, milestones become the focus of the team efforts; Team Members
work to perform the tasks associated with upcoming milestones.
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Tip: Some parts of the
Milestone Status view are
product-specific. If you are
not using the tool that
populates a particular
section of the view, that
section will not contain
data.

The Milestone Status view (Figure 5-22) identifies where a development
project stands with respect to a predefined milestone, such as an Alpha or
Beta release date. Individual developers can use the Milestone Status view
to identify the specific assignments they have to complete to meet an
upcoming deadline. By adding database queries identifying which tasks
and bugs have been assigned, individual developers can use a personal-
ized Milestone Status view as a To Do list that highlights tasks remaining
to be performed.

Similarly, project managers can use the Milestone Status view to get a
summary of the overall project status. They can leverage code volatility
statistics to identify how much of the code is changing from one build to
the next and coverage statistics to identify how much of the project
source code has been tested. By adding queries to the standard report, a
project manager can determine critical information, such as the status of
the project’s requirements and software defects.

A Milestone Status view consists of five types of information:

Figure 5-22. Sample Milestone Status View
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Tip: Milestone Status

views depend on certain Table 5-1. Mil s c
internal tags. If these tags able 5-1. Milestone Status Components

have been removed or Section Description
altered, the Milestone P

Status option might not Header Information Identifies the project, milestone and date due. When

be a\./aflable. used with the DevPartner tools, it also summarizes:
Administrators should

refer to the TrackRecord
Administrator’s Guide for
more information on
Activelink Tags. e Line Coverage— Number of lines that have been
tested over the total number of lines of code in the
components that have been run under TrueCoverage.

¢ Volatility— Number of functions that were added,
removed, or changed between builds over the total
number of functions in both builds.

e Function Coverage— Number of functions that have
been tested over the total number of functions in the
components that have been run under TrueCoverage.

Volatility Graph depicts how much of the project has changed
from one build to another. Click the triangle on the left
side of the Volatility header to display the volatility graph
for the selected milestone. This section is populated
when TrackRecord is used with the DevPartner tools.

Session Information Displays testing data generated from applications that
submit session information, such as BoundsChecker or
TrueCoverage. Click the triangle on the left side to dis-
play statistics for each component; click the triangle to
the left of a component name to display the items
belonging to that component.

CodeReview Lists of tasks and defects identified by NuMega CodeRe-
view.
Queries Results of queries included in the Milestone Status.

Creating a New Milestone Status
To create a new milestone status view, perform the following procedure:

1 From the File menu, choose New>Milestone Status to create a blank
Milestone Status view.

¢ Use the Project drop-down list to select the project you want to
profile. Optionally, click the Open button to display the project
details.

¢ Use the Milestone drop-down list to select the project milestone
you want to profile. Optionally, click the Open button to display
the milestone details.
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Click the Options button on the Milestone Status toolbar to open the
Milestone Status Options dialog box (Figure 5-23).

Figure 5-23. Milestone Status Options Dialog Box
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To share your Milestone Status view with other users, click the Shar-
ing button.

Click the Share To button on the dialog box that appears and click
the check box beside each share group with whom you want to share
the report. Click OK when you are finished.

Use the Project list to select the project you want to summarize in
the Milestone Status view.

To prohibit other users from changing the project being displayed,
select the Lock Project field option from the drop-down list.

Enter a brief description of the report in the Description field.

To display the report description on the report, select the Descrip-
tion check box.

To display code volatility information graphically, select the Code
Volatility check box and select whether the graph should depict vol-
atility over time or across builds.

¢ If you select By Build, you can use the Show Every control to
specify how many builds back you want to compare to the previ-
ous build. For example, if you choose 1, TrackRecord compares
the volatility of the current build against the previous build. If
you choose 3, TrackRecord compares the volatility of the current
build against the software three builds ago.

¢ If you choose By Date, you can specify whether you want a graph
of changes in code volatility for each day, for each week, for each
two-week period, or for each month.
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9 To display information passed to TrackRecord from other applica-
tions, select the Session Information check box. Click the Change
button and select the check box beside each component whose ses-
sion information is to be displayed.

Click OK to close the Products dialog box.

10 To include CodeReview information in the Milestone Status view,
select the CodeReview check box.

11 To see CodeReview tasks, select the Tasks check box. To see CodeRe-
view defects, select the Defects check box.

12 To include queries in the Milestone Status view, select the Queries
check box.

To add a query to a Milestone Status view, click the Add button.
When the Open Query dialog box appears, choose the query you
want to include in the Milestone Status view and click Open.

To change the sequence in which queries are displayed in the
Milestone Status view, select a query and click the Move Up or Move
Down buttons.

To delete a query from the Milestone Status view, select it and click
the Remove button.

13 When you are finished, click OK.

Filtering Milestone Status Data

78

The data that accumulates over the course of a development project
provides a rich source of information about the project. Answering
specific questions may require the filtering of session information.

You can create a filter to isolate specific information for display. For
example, you might want to see only those sessions entered by Dan
Developer.

You can filter session information by one or more of the following crite-
ria:

Developer

Build

Specific application component

Date

Operating system

Amount of memory

L K R R R B 4

For example, you could filter the session information to discover how
much debugging had been done on machines configured with more than
32 MB of memory by setting the filter to Memory is greater than 32.
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TrackRecord searches the Hardware Configuration items in its database,
retrieves a list of machine names whose configurations have more than
32 MB of memory, and then shows only those sessions run on the
retrieved list of machines.

To filter sessions in a milestone status view, perform the following proce-
dure:

1 Open the appropriate Milestone Status view.

2 Click the Filter button on the Session Information header. The Filter
Sessions dialog box (Figure 5-24) appears.

Figure 5-24. Filter DevPartner Studio Sessions Dialog Box

Filter DevPartner Sessions

Specify the sessions vou would like to filker below,

Find sessions that meet sy of the Following criteria:

Inpp\icatiun Companent j Iis equal to

=l
ekl |

I =
Field I Condition | Yalue I Remuye |

= Back I Mext = I Cancel I

Specify the types of sessions you want to retrieve and click Next.

4 On the second Filter Sessions dialog box, select the sessions you want
to include in the Milestone Status view. Click the Select All button to
select all projects.

5 When you are finished, click the Set Filter button. The Milestone Sta-
tus view displays information for the sessions you selected.

Using Volatility Statistics Dialog Boxes

The Volatility field in the header section of the Milestone Status view
displays a percentage value that represents the number of functions that
were added, removed, or changed between the current build and the
previous one. This data is available when TrackRecord is used with the
NuMega DevPartner tools.
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If you click the Volatility percentage, TrackRecord displays the Volatility

Information dialog box, which contains three tabs (Figure 5-25):

Figure 5-25. Volatility Information Dialog Box Tabs
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changed functions.

Help

Volatility Information

Changed components:

Summary Details by Component |Details by Function |

Changed saurce files:

Component MName
WBBugBench exe
vBBugBench.exe 12

Changed functions:

Mu...

Filg Name

Drlzample praject (WBEUgEEN. ..
1 Dr{Sample project ¥BEUgEeN. ..
Di{Sample project ¥BBugEen. ..
Di{Sample project ¥BBugEen. ..
Di{Sample project ¥BBugEen. ..
Di{Sample project ¥BBugEen. ..
D;iSamole oroiect\YBEuEen. .,
4

Function Name [ Typeo. ~
Private: void modAPTImplementation: APILvoid] ‘Added
private: void modAPTImplemenitation: :APIDeleteMenulvoid)
private: void modAPTImplementation: 1APIGetDrveType(void) —
private: void modAPTImplementation: 1APIGetkeyState(void)
private: void modAPTImplementation: :APIGIobalFres(void)
private: void modAPTImEl fon: APIGIobal atus(void) Added
Drjuate; void modiPTImplementation: iAPIGiohallinlocki void) | =
4 »

ok | cancel | mep |

Volatility Information [<]

Summary | Details by Component Details by Function |

Changed Functions:

Details by F
Displays the

another.

Function Name [ Component ... | File Mame: [Typeo. =|
private: void frmiain: cmdAbout_,,.  VBBugBench... Digamplep... Added J
private: void frmMain: icmdabout_, .. VBBugBench...  DiiSample p..  Remave
private: void frmMain: :.cmdClose_C... VBBugBench... DiSamplep... Added
private: void frmMain: :.cmdClose_C... Di\Sample p...  Remove
private: void frmMain: emdTestall .. Di\Sample p...  Added
private: void FrmMain: iemdTestal_... Diysamplep...  Remove
private: void frmMain: icmdTestGra... VBBugBench... DiiSample p...  Added
private: void frmMain: icmdTestGra... VBBugBench... Diisample p.. Remave
private: void frmMain: icmdTestOn,.,  VBBugBench...  Diisample p...  Added
private: void frmMain: icmdTestOn, . VBBugBench...  Diisample p..  Remave
private: void frmMain: (Form_Load(... VBBugBench... DiiSamplep.. Added
private: void FrmMain: tForm_Load... Diysamplep...  Remove
private: void FrmMain: [SelectFunchi. . Diysamplep...  Added
private: void FrmMain: [SelectFunci. . Diysamplep...  Remove
private: void frmMain: sstPains_Cli.,. VBBugBench... DiiSample p.. Added
private: void frmMain: sstPains_Cli... VBBugBench... Diisample p.. Remave
private: void FrmMain: ttvwAPI_Coll... VBBugBench... DiiSamplep.. Added
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Interpreting the Volatility Graph

unction Tab —
list of functions

that have been added,
modified, or removed
within a project’s source
tree between one build and

You can display a graphical summary of the volatility between builds by
opening the Volatility section of the Milestone Status view. To open the
Volatility section, click the triangle to the left of the Volatility header.
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The point plotted above each build label represents the percent change
between that build and the previous one. If you specified that you
wanted to display volatility across more than one build at a time, the plot
pointed above the label represents the percent change between that build
and the appropriate earlier build.

Utilizing the Calendar View

To view project information in the context of some span of time, use
TrackRecord’s Calendar view. The Calendar view (Figure 5-26 and Figure
5-27) functions as an appointment book and To Do list, where Track-
Record automatically categorizes and displays the appropriate data by
date and time.

By default, TrackRecord displays all uncompleted items for a given day or
week. Timed Tasks are displayed according to their scheduled start date/
time, and Tasks (including Defects and Feature Requests) are displayed
according to their due date. Timed Tasks take place at specific times and
for specific periods. Regular Tasks may have deadlines, but are otherwise
open-ended.

The data displayed in a calendar is determined by the query run by the
calendar view. You can customize the information displayed by your
calendar by changing the query. Refer to Chapter 4, “Retrieving Data” for
more information on queries.

Depending on your preferences, the daily or weekly Calendar view
displays a simple list of your appointments and tasks or a tick-marked
schedule of each day. By changing the Calendar view’s query, you can
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display different data or dates. You can also maintain and display multi-
ple calendars simultaneously.

Figure 5-26. Sample Calendar by Day Views
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Figure 5-27. Sample Calendar by Week Views
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Creating Your Default Calendar

The items displayed in a calendar are determined by the query run by the
Calendar view. Before setting up your default calendar, create a query for
the items that you want displayed. Refer to “Understanding Queries” on
page 45 for information about creating queries.

To configure your default calendar, perform the following procedure:
1 From the File menu, choose New>Calendar.

2 (Click the Options button. The Calendar Preferences dialog box (Fig-
ure 5-28) appears.

3 Specify your calendar preferences:
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Tip: Refer to Chapter 4,
“Retrieving Data” for
additional information on
queries.

Adding Tasks to the

84

Figure 5-28. Calendar Preferences Dialog Box
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4  Click OK to display the Calendar view.

TrackRecord stores your Calendar view settings and uses them any
time you display a new calendar.

Calendar
Note:

(default query
displays all incom-
plete tasks and timed
tasks due each day)

If the query specified in your Calendar Preference dialog box does

not search for date and time fields, you will not be able to enter an
appointment in this way. The default calendar query uses appropri-

ate fields.

Perform the following procedure to add a task to a calendar:

1 Open your TrackRecord calendar.

2 From the File menu, choose New>Calendar. TrackRecord uses your
default calendar settings to display your current calendar.

3 Click the point on the time bar representing the starting time of the
task or appointment, and drag across to the ending time. Release
your mouse button.
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For example, if you are entering an appointment scheduled to start at
9 AM and end at 10 AM, you would drag from the 9 to the 10 on the
time bar. The Timed Task form (Figure 5-29) appears.

Figure 5-29. Timed Task Form
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Description: -
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Date Completed:

|_ El I~ Completed

Location:

Enter information about the appointment, such as a one-line sum-
mary (which will appear in your calendar), in the form fields. Track-
Record fills in the starting and ending date and time fields for your
appointment automatically.

When you are finished, click the Save and Close button. The new
appointment appears on your calendar.
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Chapter 6
Using TrackRecord’s WebServer

4 Understanding WebServer

& Exploring the WebServer Interface
& Using TrackRecord WebServer Forms
& Creating a New Item

& Working with File Attachments

& Searching With WebServer

4 Opening an Outline Report

Understanding WebServer

TrackRecord’s WebServer allows you to access the TrackRecord database
through a Web browser, such as Microsoft Internet Explorer or Netscape
Navigator/Communicator.

Tip: Refer to the When you log in to TrackRecord through the WebServer, TrackRecord

TrackRecord accesses your user information in the database just as though you had

Administrator’s Guide for  15gged in through the TrackRecord Windows client. If you have set

administrative .

information. preferences such as a Home Page or favorite reports through your
Windows client, those items will be maintained in the WebServer client
as well. The WebServer also recognizes your membership in Groups and
Share Groups and allows you to run the same reports you run through
the Windows client.

While using the WebServer, you can create new items, view and modify
existing items, and view existing Outline Reports. You cannot create new
queries, Outline Reports, or other reports.
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Notes about the WebServer
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The WebServer uses the same item form as the TrackRecord Windows
client, but has a few important differences.

Entering Information

You enter information just as you would in the Windows client with
these exceptions:

L 4

For any date fields in the Web client, always enter date information
using the same date format as that used by the computer running the
WebServer. This information is displayed next to the Date field label.
For example, if the WebServer machine is configured to use dates in
the format dd/mm/yyyy, you should enter a date as 28/09/2001, not
09/28/2001. To ensure that the correct format is used when selecting
dates, click the Calendar button to specify dates from a graphical cal-
endar instead of entering a date with the keyboard. This will open
the calendar and you can double-click a date to select the day you
want to enter. Note that alphabetic characters are not supported in
dates.

Note: The Calendar button only works with Microsoft Internet Explorer.

4

4

To update an existing TrackRecord item from the WebServer inter-
face, you must open an Outline Report that includes that item and
then click the item’s link.

Do not use an ampersand (&), a quote sign (“), a greater than sign (>),
or a less than sign (<) in any of your fields that are going to be dis-
played on the Web. If you do, you will not be able to open up the
Web page.

Do not use field names greater than 40 characters in length.

Ensure that there are no spaces at the end of a field name.

Outline Reports

When accessing an Outline Report through the WebServer, note the
following differences from Outline Reports in the Windows client.

4
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You can open and close all headers at once with the Expand All and
Collapse All buttons in the Status Bar (Figure 6-2). Note that Expand
All may take a some time to complete, depending on the contents of
the headers.



¢ Ifareport contains more than ten items in a header, when the header

is expanded the first ten items are displayed. Figure 6-1 illustrates
how the arrows are used to display the returned items.

Figure 6-1. Navigation Arrows for Viewing Returned Items

Number of Shows Previous Shows All
Results 10 Items Returned Items

Shows Next

10 1t
(2 ernsl [= = Al b | T/ oms

Displays Previous Item”  Shows Next ltem

When you open a header, the report scrolls to position the open
header at the top of the Work Area.

If you click on a drop-down list that causes TrackRecord to run rules,
TrackRecord must access the database to run those rules. The item
will be partially saved when the database is accessed. Once the item
has been partially saved, clicking the Cancel button will display a
message that a version of the item has been saved and you cannot
cancel your changes. You must manually restore the values that you
want saved.

Entering and Exiting the WebServer

Required: A non-admin user is prevented from a login to the WebServer if

they have not previously performed a login to the full TrackRecord
client.

Logging In to WebServer

To log in to TrackRecord WebServer, perform the following procedure:

1

Run a Web browser such as Microsoft Internet Explorer or Netscape
Navigator.

Enter http://<your servername>/trackrecord/welcome.htm]l
in the Destination field of your Web browser and click Enter.

Note: Ask your TrackRecord administrator what value to enter for <your

servername>.

For example, if your server was named sfal0072, you would enter
http://sfal0072/trackrecord/welcome.html.
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The TrackRecord WebServer Login page (Figure 6-2) appears.

Figure 6-2. TrackRecord WebServer Login Page

/3 Compuware TrackRecord on th16388x - Microsoft Internet Explorer provided by Compuware Corporation B[] E3
| Fie Edt Wew Fawories Tods Help |

« =+ 0 AN = D=
BEck Feli/ze] Stop  Refresh  Home Search Favorites  History ail Print Edit Discuss
=l
ZTrickRecord
WebServer Login

User Name
Password
Database: |SAMPLE

Ok Feset

Copyright 1983-2000 by Compuware Corparation. All rights resene d
Formore information on TrackRecord, click here,

Enter your user name, password, and the name of your TrackRecord
database.

Click OK. The TrackRecord WebServer main window (Figure 6-3)
appears.

Logging Out of WebServer

To log out of TrackRecord, click the Logout link in the Control Area of
the WebServer window.

You are automatically logged off if you close the browser or access a
different URL. You should use this browser window exclusively for Track-
Record tasks. Use another browser window to access other URLs.

Changing the Database Name Appearing on Login Screen

To change the database that appears on the login screen:

1
2
3
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Click the task bar’s Start button and choose Run.
Type Regedit in the Open field. Click OK.

Navigate to the following path: H_KEY_LOCALMACHINE>SOFTWARE>Com-
puware>TrackRecord.

Right-click on databaseDir and choose Modify.

In the Edit String dialog box, change the value data from Default to
the name of your database.



Exploring the WebServer Interface

The WebServer window (Figure 6-3) is your Web interface to the Track-
Record database. You use this window to create and modify items and
view reports. The WebServer window consists of three areas that are
explained in the following sections:

¢ “Control Area” on page 91
¢ “Status Bar” on page 92
¢ “Work Area” on page 92

Figure 6-3. TrackRecord WebServer Main Window. The links are shortcuts to your
most common tasks. The links on your screen may differ from the illustration, since
they depend on your user settings.

Control TrackRecor ===s ,.
By Compuware Defects Assigned to Me
Area
| Mew Defect | Open Defects Assigned to Me | Manage | Logout | User Options | Search | Help | Guided Tour |

Status —————— Dpefects Assigned to Me Expand | Collapse | Refresh |
Bar £ Defects: Assigned to me

& Unreviewed

£ Open

# Pending Yalidation
Work
Area

Control Area

The two drop-down menus at the top right of this area allow you to
choose to create a new item or to open a report. The available links
include:

¢ The first link (New Defect by default) allows you to create a new item
of your favorite type. If your favorite type is set to Task, for example,
this link will be New Task.

¢ Shortcut to your Home Page report if you or your administrator has
specified a Home Page in TrackRecord. If a Home Page has not been
specified, this link is not displayed.

¢ For administrators, the Manage option is available. This link is not
displayed if you are not logged on as an Administrator.

¢ The Logout link allows you to log out of the WebServer.

The User Options link displays the TrackRecord WebServer version
number, the name of your database and your username, and allows
you to change your password.

¢ The Search link allows you to search for information through the
WebServer.
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¢ The Help link displays information about using the WebServer.
¢ The Guided Tour link opens the TrackRecord Guided Tour.

Status Bar

The Status bar may contain a status message, such as an error or a
message indicating communication with the server, or a series of dots
that are displayed to indicate that the WebServer is performing an action.
It may also contain information about the item or report you are
currently viewing, including the title of the page and buttons that
operate on the current item or report.

The contents of this area vary. For example, when you are working on a
Defect, the status bar contains a Cancel button and a Save button.

Work Area

The Work Area displays the selected item or report. When you first access
the WebServer, your TrackRecord Home Page is displayed in the work
area by default. If you have not set a Home Page, the work area will be
empty.

Database and User Name

The database name and user name appear on the browser's title bar. For
example, the database "default" and the username "Admin" would appear
as (default:Admin). If different from the WebServer name, the database
server name will also be displayed. For example:

Compuware TrackRecord on WebServername (servername|
databasename:username)

WebServer Window Notes
Note the following when using the WebServer window.

¢ TrackRecord spawns a separate browser window in which to run the
Web application. This window should be used exclusively for run-
ning TrackRecord. If you use this window to access another URL or if
you close the window, your TrackRecord session will be terminated.

¢ The context menu (right-click menu) Open Item in New Window
option is not supported. Although a window will be opened, it will
not be functional. To display two items simultaneously, open another
browser window, enter the URL for the welcome.html page, and log
into TrackRecord from this window.
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Using TrackRecord WebServer Forms

Two buttons are found at the bottom of most item forms: Change
History and Printable Page.

Change History Button

When clicked, the Change History button brings up a window (Figure 6-
4) that provides an audit trail of the changes made to an item over time.

When an item is created or modified, an entry is added to the change
history list for that item. If a person made several changes to an item

during a single session, each change will be noted separately.

Figure 6-4. WebServer Change History Window
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Operating System set to Windows 98
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Printable Page Button

When clicked, the Printable Page button brings up a window (Figure 6-5)
that provides a print preview of the item and displays the information in
a printer friendly format.

Figure 6-5. Printable Page Window
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Creating a New Item

You can use the WebServer interface to create new TrackRecord items.

Caution: Compuware recommends that you review the “Notes about the
WebServer” on page 88 before beginning this procedure.

To create a new TrackRecord item, execute the following procedure:

1 Open the TrackRecord WebServer main window as described in
“Entering and Exiting the WebServer” on page 89.

2 From the New drop-down menu, select the type of item you want to
create. The Work Area displays a form allowing you to enter the new
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item. The Status Bar displays buttons appropriate for this item, such
as Cancel and Save.

Figure 6-6. New Defect Form in WebServer Window

P TrackRecord==

By Gompuware Defect Status Report
| Mew Defect | Open Defect Status Report | Manage | Logout | User Options | Search | Help | Guided Taur |
Defect Cancel | Save |
W Status: Lnreviewed
Identifier Priority Entered by Date Entered oo
[poooa Mone =| open | Mone | open Bosz3r2002
Surnrmary
Project Assigned to Fix by Milestone
| MNaone j Open I Mane j Open | R j Open
Description
Status Severity
|Unreviewed j I Tane j Open

3 Complete the fields in the form. Required fields are identified with
red field labels. Note the following items:

¢ Asingle line text field can contain up to 255 characters.

¢ A multi-line text field can store up to 65,535 characters of infor-
mation.

¢ A numeric field can store a number between 0 and
4,294,967,294.

4 When you are finished, click the Save or Cancel button on the Status
Bar.

Working with File Attachments

Note: This function will not work unless you are running Microsoft Internet
Explorer and your Web server is Microsoft Internet Information Server
(l1S) 4.0 or higher or iPlanet Web server 4.x.

TrackRecord’s WebServer client allows you to attach files, open attached
files, and delete attachments.

The TrackRecord limit on file attachment size per item is 12 MB. After
attachment, these files are compressed, stored in attach.dat, and can only
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be viewed through the TrackRecord client or WebServer. Their

compressed physical size when stored in the database can be notably
smaller than the original file size.

Furthermore, attachments are only read into memory when viewing or
extracting them, so the fact that the attachment table can become rather
large on disk has no affect on performance or memory usage.

Attaching a File to a WebServer Form

To attach a file, repeat step 1-3 of the procedure for “Creating a New
Item” on page 94. Add the following steps:

1 Click the New link next to the Attachment field.

Figure 6-7. Attaching File To Form

- Hew RIS ~
TrackRecord == o
By Gompinara E LN Defacts Assigned to Me -

| Mew Defect | Open Defects Assigned to Me | Manage | Logout | User Options | Search | Help |

Defect Cancel I Save |
= |
=
Functional Areas Keywords Attachments
Add Add Add
Mews Mew Mew
Cpen Cpen Open |
Delete Delete Delefe Attachment
field
Reported by Source Files Duplicate Defects
Add Add Add
IMews Mews Mew
Open Open Open
Delete Delete Delete

2 Enter the path to the file you wish to attach or click the Browse but-
ton to locate the file.

3 Optionally, enter a description of the attached file.
4  Click the Save button to return to the browser.

When you are finished, click the Save button on the Status Bar.

Opening Attachments

To open an existing attached file, select the desired item and click the
Open link next to the Attachment field (Figure 6-7). Click on the
Attachment link to view the attached file in a new window. If you make
any changes to the description field, be sure to click the Save button. If
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you have not made any changes to the attachment, click Cancel to
return to the browser.

Deleting Attachments

To delete an attached file from a TrackRecord form, select the item and
click the Delete link next to the Attachment field (Figure 6-7). Click the
Save button when you are finished.

Searching With WebServer

To find database information quickly, you can perform a search rather
than create a view. The WebServer offers a simple search to allow you to
find items that contain a specified text string. For example, you can
search for all defect items that contain a specific name in any string field.
To search the WebServer, follow these steps:

T Open the TrackRecord WebServer main window as described in
“Entering and Exiting the WebServer” on page 89.

2 Select the Search link from the WebServer menu. The TrackRecord
Search window appears.

Figure 6-8. TrackRecord Search Window

3 TrackRecord Search - Microsoft Internet Explorer provided by ... [E[=] E3

Search Criteria:

| Search |

Please Note:

Searching andfor Sorting can take a substantial amount of
time depending on size of the database and the size of the
recordset returned.

3 Enter the text string you want to find in the Search Criteria field.

Any item that contains the specified text string in any field will be
displayed. You can enter partial words to find wording variations. For
example, you can enter veri to find all items that include the words
verification, verify, verified, or unverified.
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4 Click the Search button. The Search Results window lists all items

5

6

that meet your search criteria.

Figure 6-9. Search Results Window

3 TrackRecord Search - Microsoft Internet Explorer provided by ... [E[=] E3

==

Search Criteria:

fmemary | S=sich |

Please Note:

Searching andfor Sorting can take a substantial amount of
time depending on size of the database and the size of the
recordset returned.

(ems - 1 of §) [ = A1l -1

Type Abbrev
Chaice Fields Memary Loss
H
|@ 1] ’_’_Eﬂ Local intranet i

To display the contents of one of the items, click the appropriate
entry.

When you are finished, close the window.

Opening an Outline Report

98

Any Outline Report that is available to you through the Windows client
is also available through the WebServer.

Caution: Compuware recommends that you review the “Notes about the
WebServer” on page 88 before beginning this procedure.

Complete the following procedure to open an Outline Report:

1

TrackRecord User’s Guide

Open the TrackRecord WebServer main window as described in
“Entering and Exiting the WebServer” on page 89.

Select the Outline Report you want to display from the Open list. If
you have identified a Home Page report, you can open your Home
Page by clicking on the link in the Control Area.

Click a report header to show the items within that header.

You can click the Expand All button to display all items in the
report, or click Collapse All to hide items. You cannot collapse
individual headers.



4 To update an item in the TrackRecord database, click its reference in
the Outline Report.

5 To close the report, open another item or report.
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Chapter 7
Working With Templates

4 Understanding Templates

& Creating Templates

& Setting the Default State

# Associating Templates with a Header

Understanding Templates

Templates simplify data entry in TrackRecord by automatically entering
information in specified fields when you create a new item. This preset
format is used as a starting point for a particular application so that
format does not have to be recreated each time it is used. For example,
you can create a template for new Defect items that enters your name,
your computer configuration, and other information in the appropriate
fields in the Defect form. You can create templates for any TrackRecord
data type, such as Team Members, Tasks, or Defects.

Caution: When creating a template, be careful to leave blank any auto-
incrementing or auto-initialized fields. Otherwise, the contents of the
template will override the automatic value inserted by TrackRecord.
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Figure 7-1 illustrates how TrackRecord enters information in a Defect
form when it is first opened.

Figure 7-1. Templates Prefill Information in Forms

Personal template supplies
Reported By name

10

A

Project name supplied ...is overridden by Pioje

by global template supplied by personal

(Vertigo)... template (Millennium)

¢ The user’s personal Defect template specifies that “]J. Doe” should be
automatically entered in the Reported By field on the Defect form.

¢ The global template specifies that the default status for new Defects is
“Unreviewed”. Note that the user’s personal template does not spec-
ify a value for that field. TrackRecord automatically enters “Unre-
viewed” in the Status field on the Defect form.

¢ The global template specifies that the default project name for new
Defects is “Vertigo”. However, the user’s template, which overrides
the global template, specifies that new Defects should default to
“Millennium” for the project name, so TrackRecord enters “Millen-
nium” in the Project field on the Defect form.

Templates can be global, shared to selected work groups, or private.
Private templates are applied after global and shared templates and can
therefore be used to override global and shared templates.
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When Are Templates Applied?

TrackRecord applies templates in two circumstances: when you create
new items directly and when you create new items from within an
Outline Report.

When Creating Items Directly

When you create an item, TrackRecord automatically inserts values from
templates for that type of item. Templates use the principles of data type
inheritance determining how to populate fields (Refer to “Understanding
Data Type Inheritance” on page 17 for more information). The values
that will be inserted are determined by a nested set of sources, which are
applied in the following order:

1 Global template for a parent of the new item

2 Template for a parent of the new item shared with the user’s work-
group(s)

3 User’s personal template for a parent of the new item

4  Global template for that type of item

5 Template for that type of item shared with the user’s workgroup(s)

6 User’s personal template for that type of item

When a value for a field is found at one level, TrackRecord ignores values
specified at lower levels. For example, if a user’s personal template speci-
fies “Colossus” as a project name and the global Defect template specifies
“Millennium,” TrackRecord uses “Colossus” because it is a higher prior-

ity.

Templates and Items Created from an Outline Report

Templates provide a context-sensitive formula for items created in an
Outline Report section. When you use templates to create items from
within an Outline Report, you can specify as many templates as you
require to prefill the item’s fields.

For example, Figure 7-2 illustrates an Outline Report that lists Defects by
status (Unfixed bugs, Fixed bugs), with separate child headers for each
Defect priority (1, 2, 3) under each status header. If you add a Defect
template to the Unfixed bugs status header, the phrase Unfixed bugs will
automatically be inserted into the Status field when a new Defect is
created from within that header. You could then add a Defect template to
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each child header under Unfixed bugs to insert the appropriate value in
the Defect Priority field.

Figure 7-2. Adding Templates to Headers Simplifies Data Entry

A template attached B Bugs Tol=]
to the Unfixed bugs ; &)|

header would insert YAl active bugs =l
a status of Unfixed——1 © unfized bugs

Insert Header = "“\| .l.].l| Options. .. | (b [rate: |

H @ Priority 1 (5 items)
bUgS into new @ Priority 2 (7 items)
Defects " © Priority 3 (4 items)

A template attache’d/ @ Fized bugs (7 items)

to each Priority
header would insert
a different priority
into new Defects q |

¥

AV

When someone using this Outline Report wants to add a new Defect, he
or she would right-click the appropriate child header and choose New
Defect from the shortcut menu. TrackRecord would automatically fill the
Status field with the information supplied by the parent header’s
template and the Priority field with the information from the child
header’s template.

Templates associated with child headers override templates associated
with parent headers. For example, if the template linked to the parent
header inserts “Millennium” in the Project field of a new Defect and the
child header inserts “Vertigo,” TrackRecord would insert “Vertigo”
whenever a new Defect is created from within the child header.
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Figure 7-3 illustrates how TrackRecord fills fields in a new item with
information supplied by templates attached to headers within an Outline
Report.

Figure 7-3. Precedence of Templates From Within an Outline Report

/
Unreviewed Statust—"|

Creating Templates

To create a new template, follow these steps:
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1 From the File menu, choose Manage>Templates. The Manage Tem-
plates dialog box (Figure 7-4) appeats.

Figure 7-4. Manage Templates Dialog Box

Show: IAII Templates

Type

| Description | Apply Always | Cner

Assignrnent
Assignrnent
Assignrnent
Assignrnent
Assignrnent
Build
Defect
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DevPartner 5...

Default Assignment ...
Priority 4 template
Priority 3 template
Priority 2 template
Priority 1 template
Default Build Template
Default Defect temp...
Today, - Default De...
Today: Default Mote. .,

es

es
es
es
es

<Admin =
<Admin =
<Admin =
<Admin =
<Admin =
<Admin =
<Admin =
<Admin =
<Admin =

[ ]

| Skakus | I
Shared

Shared Edit.. |
Shared

Shared Delete |
Shared
Shared
Shared
Shared
Shared

Close | Help |

2 Click the New button to display the Choose a Type dialog box.

3 Select the type of item for which you want to create a template and
click the New button.

An Item form (Figure 7-5) for the selected type appears. The Identifier
and Summary fields display a blue key icon beside the label to signify
that these fields are not part of the template.

Figure 7-5. Template Form for Build Item

Blue key
indicates field

ES Build Item

|G gseveanddiose - & 4 B @ 0 2 ] options..

[_[Of>]

Trem |L\nl6 | Change History |

identifiesar

describes the
template
instead of
establishing
default infor-
mation for a
field in a new
item

[T

Profect Version:

Build Number:

Submitted by:

DatejTime:

[ <rione>

Corponents:

B[

4 Enter a description for this template in the Summary field. The Sum-
mary field is used to identify the template in the Manage Templates
dialog box (that is, the Summary becomes the template name).

5 Enter information in the fields you want the template to prefill.
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6 Click the Options button to open the Template Options dialog box
(Figure 7-6).

Figure 7-6. Template Options Dialog Box

Template Options E

Qnwner: IAdmin j

Skatus: I Mot Shared sharing. .. |

I~ Apply this template ko all new ikems

Cancel | Help |

7 Optionally, specify whether you want to share this template with
other users.

<& Click the Sharing button to open the Sharing dialog box (Figure
7-7). Click the Share To button and then select the check box
next to each group with which you want to share the template.

Figure 7-7. Sharing Dialog Box

Sharing E
€ Mot shared
" share to al
% share ko . .
s Template is shared with Team
Share Group | Member I .
Ol Accounting o Members in the Colossus and
[ Colossus M Millennium workgroups, but
[ tillenium Mo

not Team Members in the
Accounting workgroup.

OF I Cancel | Help |

¢ If you have opened the Sharing dialog box, click OK to return to
the Template Options dialog box.

¢ If you want to use this template whenever you open a new item
of this type, select the Apply This Template to New Items check
box.

¢ When you are finished, click OK to return to the template form.
8 Click Save and Close.
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Setting the Default State

To set the default state through the use of a template, perform the follow-
ing steps:

1 From the File menu, choose Manage>Templates. The Manage Tem-
plates dialog box appears. If necessary, use the Show drop-down
menu to view a subset of templates.

2 If an appropriate template already exists, select it and click the Edit
button to make any modifications. If an appropriate template does
not exists, click the New button and select the type.

3 In the Summary field, enter a descriptive name for this template.
This name will identify this template in the Manage Templates dialog
box.

4 In the Status field, select a default value for Status, such as Unre-
viewed or Open.

5 Click the Options button to open the Template Options dialog box.

6 Ensure that the Apply This Template to All New Items option is
selected.

7  Click the Sharing button and select the Share to All option. Click
OK.

8 When all template items have been set, click Save and Close. When
a user creates a new item of this type, the initial status will be set.

Associating Templates with a Header

To associate a template with an Outline Report header, follow these steps:
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Open the Outline Report to which you want to link a template.

Right-click the header to which you want to add a template and
choose Set Templates. The New Items tab on the Header Properties
dialog box (Figure 7-8) appears.

Figure 7-8. Header Properties Dialog Box — New Items Tab

Header Properties E

General Mew Items |COIumns I Print Options I

—Mew Ikem Type
Include & command in the context menu of this header to create a new item:
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— Templates

Items created using the command in the context menu of this header, or the context menu of
items in this header, will use the following templates:

Available templates: Used for this header:

Add = |
< Remove |

OF I Cancel | Help |

In the New Item Type section, specify the item types that you want
to be able to add by right-clicking the header.

<& Select the Of type option and choose the data type from the list
on the right.

¢ To open the same types from this header as you can from the par-
ent header, select the Of type <type>, as specified in the parent
header button.

Identify the templates you want to use when creating new items from
within the selected header.

Use the Type drop-down list to select the type of item for which you
want to create templates. When TrackRecord displays the list of
templates applicable to the type you select in the Available templates
list, select the one you want to use and click the Add> button.

You can use more than one template when you create items from
within an Outline Report header. For example, construct one
template to insert your name and a second template to insert a
project name. This lets you reuse the first template when you set up
templates for other headers in the Outline Report.
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When you create more than one template for an Outline Report
header, information from the templates at the top of the list is used
before information from lower templates. For example, if the first
template in the list specified a project name of “Colossus” and a
lower template specified a project name of “Millennium,” Track-
Record would use “Colossus” when creating a new item.

When you are finished, click OK.
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Integrating TrackRecord with
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Using TrackRecord with Text Editors

Integrating TrackRecord with Graphics Applications
Synchronizing TrackRecord with Microsoft Outlook
Connecting TrackRecord to Microsoft Project
Integrating TrackRecord With Visual Basic

Using TrackRecord With Visual C++

Utilizing TrackRecord with Version Control Systems
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Integrating TrackRecord With Compuware Products

Using TrackRecord with Text Editors

TrackRecord makes it easy to copy data from Outline Reports into other
applications, including text editors, spreadsheet programs, and electronic
mail applications. When you paste data from an Outline Report into an
application that supports Rich Text Format (RTF), such as Microsoft Word
or Microsoft Outlook, the report’s columns, fonts, and format are
preserved in the new document.

Tip: Information copied Embedding an Outline Report in a Text Document

from TrackRecord to other
applications is embedded To embed an Outline Report in a text document, follow these steps:

statically. It will not 1 Select the headers or items you want to copy and from the Edit
change when the data in

TrackRecord changes. menu, choose Copy to add the Outline Report data to the Windows
Clipboard.

2 Activate the document window for your target application.

3  From the Edit menu, choose Paste.
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If you copied an Outline Report header, the header you selected, its
child headers, and any sibling headers below the one you copied
appear in the target document window. If you selected an Outline
Report item, that item is pasted to the target document.

Optionally, update the style information for pasted data to make it
conform to your document standards.

TrackRecord information pasted into other applications uses two
styles: TR Header and TR Item. After you have pasted information
from TrackRecord into a text editor, you can quickly adjust the
typefaces, type sizes, and other properties of the embedded informa-
tion by changing settings for these styles.

Integrating TrackRecord with Graphics Applications

You can copy graphs generated by TrackRecord into graphics applica-
tions, such as Microsoft Paint. After you paste a TrackRecord graph, you
can modify the graph using the application’s tools.

Additionally, you can paste graphs generated by TrackRecord into text
editors, spreadsheet programs, and electronic mail applications that can
accept bitmap images. For example, you can paste a bar graph from
TrackRecord into Microsoft Word, Microsoft Excel, or Microsoft Outlook.

Pasting a TrackRecord Graph into Another Application

To paste a TrackRecord graph into another application, perform the
following procedure:

Tip: Graphs copied from 1
TrackRecord to other
applications will not

change when the data in
TrackRecord changes. 2
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Generate the graph from the appropriate Outline Report. Refer to
“Working with Graphs” on page 70 for information on formatting
TrackRecord graphs.

From the Edit menu, choose Copy to add the TrackRecord graph to
the Windows Clipboard.

Activate the window for your target application.
From the Edit menu, choose Paste.

Optionally, if the target application lets you edit bitmap images,
change the colors or layout of the TrackRecord graph.



Synchronizing TrackRecord with Microsoft Outlook

Those who use Microsoft Outlook can import TrackRecord task items into
Outlook. It then displays TrackRecord task items as Outlook tasks. You
can check off a completed task in Outlook. After synchronization, the
task will also be shown as completed in TrackRecord. You can synchro-
nize the applications periodically to keep your items up-to-date in both
applications. Optionally, tasks marked as completed in either application
can be removed from Outlook during the next synchronization.

The following table details how TrackRecord tasks appear in Outlook
tasks:

Table 8-1. How TrackRecord Tasks Appear in Outlook

Outlook Field Contents

Subject Default value of item (ldentifier and Summary by default)
Due Date Date Due field

Priority Mapped from Priority field

Body Text of the format:

“Project: <Project> <Description>” where Project
and Description are taken from the corresponding TrackRecord
fields

Category Set to the text TrackRecord

Caution: Three additional user-defined fields are added to the Outlook
task item: TRIdentifier, Project, and Database. These fields maintain the
link with TrackRecord and should not be edited.

Note: Outlook 2000 users will find a TrackRecord menu on the Outlook
menu bar after a TrackRecord installation. Outlook 97/98 users must
run a separate program called TROut1ookSync.Exe to set synchroni-
zation options and to synchronize tasks.

Synchronizing TrackRecord and Outlook 97/98

1 In Windows Explorer, locate the TrackRecord directory and double-
click the TROut1ookSync.Exe icon in the TrackRecord program group.

2 If the TrackRecord login screen appears, enter your user name and
password. Click OK.

3 Click Options on the TrackRecord Task Synchronization dialog box.
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Tip: If you want
synchronization to occur
automatically, you can
use a feature like the
Microsoft Scheduler to
periodically launch the
TrackRecord Task

Synchronization program.

Use the “/synch /silent”
arguments to prevent
dialog boxes from
appearing.
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Note:

You can also use the “/sync” command line parameter to automati-
cally begin a synchronization upon launching the application. If this
is coupled with a “/silent” parameter, no user interface will be shown
and the synchronization will simply occur. For example: C: \Program
Files\Compuware\TrackRecord\TROutlookSync.exe/sync.

4 On the Synchronization Options dialog box (Figure 8-1), set or
change options as necessary:

Note:

Note:
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If the selected query returns non-task items such as Defects or
Projects, they will not be imported into Outlook; only tasks (or items
that inherit from tasks) can be imported.

Figure 8-1. Synchronization Options with Microsoft Outlook

Synchronization Options E
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¥ Bemove tasks from Outlook when they are completed
¥ Exclude completed TrackRecord tasks

Specify how TrackRecord Priorities should map to Outlook:

TrackRecord Priority | Outlook Importance |
1-High High
2 - Medium High
3-Low Mormal
()8 I Cancel |

Select a TrackRecord query for retrieving task items by selecting a
query from the drop-down list. By default, TrackRecord will
search for a query named My Outlook Tasks in the current data-
base and use that to determine which items should be synchro-
nized. If that query is not found, it will scan all task items and
synchronize any tasks that are assigned to the current user and
not marked as complete. Changing the query only affects what
new items will be imported/synchronized with Outlook. Any
items that have already been imported into Outlook will remain,
and will continue to be synchronized with TrackRecord.

Choose whether to remove completed tasks from Outlook by
selecting or clearing the check box. By default, once an item is
marked as complete, it is removed. When this option is cleared,
completed items will not be removed and will continue to be
synchronized.

You cannot mark tasks as incomplete from within Outlook. If you
mark a completed task as incomplete in Outlook, it will be remarked
as complete next time you synchronize.



¢ Choose whether to exclude TrackRecord tasks already marked as
complete by selecting or clearing the check box. By default, com-
pleted TrackRecord tasks in the query are not added to Outlook.
When this option is cleared, even the completed tasks will be
added.

Note: If the Remove Completed Items option is selected while the
Exclude Completed tasks is cleared, all the completed tasks will be
added to the Outlook Tasks folder and then moved to the Deleted
Items folder.

¢ Select how to map TrackRecord priorities to Outlook by double-
clicking an entry in the Outlook Importance column and select-
ing High, Normal, or Low. This control allows you to map each
TrackRecord priority to an Outlook priority. If a priority has not
been mapped in TrackRecord, or has no priority, it will be set to
Normal in Outlook.

5 Click OK when you are finished.
6 Click the Synchronize button.
7 Click Exit when finished.

Synchronizing TrackRecord and Outlook 2000

If you have Outlook 2000, the TrackRecord client installation process will
install an add-in that allows you to access TrackRecord Task Synchroniza-
tion. From the Outlook Tools>TrackRecord menu, there will be three
menu options: Synchronize, Edit Options, and Change Login. To
synchronize using Outlook 2000, perform the following procedure:

1 In Outlook, choose Tools>TrackRecord>Options. The Synchroniza-
tion Options dialog box (Figure 8-1) appears.

2 On the Synchronization Options dialog box (Figure 8-1), set or
change options as necessary:
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Note:

Note:
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If the selected query returns non-task items such as defects or
projects, they will not be imported into Outlook; only tasks (or items
that inherit from tasks) can be imported.

Figure 8-2. Synchronization Options with Microsoft Outlook
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Select a TrackRecord query for retrieving task items by clicking
the drop-down list and choosing a query from the supplied list.
By default, TrackRecord will search for a query named My Out-
look Tasks in the current database and use that to determine
which items should be synchronized. If that query is not found,
it will scan all task items and synchronize any tasks that are
assigned to the current user and not marked as complete. Chang-
ing the query only affects what new items will be imported/syn-
chronized with Outlook. Any items that have already been
imported into Outlook will remain, and will continue to be syn-
chronized with TrackRecord.

Choose whether to remove completed tasks from Outlook by
selecting or clearing the check box. By default, once an item is
marked as complete, it is removed. When this option is cleared,
completed items will not be removed and will continue to be
synchronized.

You cannot mark tasks as incomplete from within Outlook. If you
mark a completed task as incomplete in Outlook, it will be remarked
as complete next time you synchronize.

Choose whether to exclude TrackRecord tasks already marked as
complete by selecting or clearing the check box. By default, com-
pleted TrackRecord tasks in the query are not added to Outlook.
When this option is cleared, even the completed tasks will be
added.



Note: If the Remove Completed Items option is selected with the Exclude
Completed tasks cleared, all the completed tasks will be added to
the Outlook Tasks folder and then moved to the Deleted Items folder.

<& Select how to map TrackRecord Priorities to Outlook by double-
clicking an entry in the Outlook Importance column and select-
ing High, Normal, or Low. This control allows you to map each
TrackRecord priority to an Outlook priority. If a priority has not
been mapped in TrackRecord, or has no priority, it will be set to
Normal in Outlook.

3 Synchronize tasks by choosing Tools>TrackRecord>Synchronize
Tasks. The TrackRecord Task Synchronization Status dialog box
appears.

4 Close the dialog box when the synchronization is complete.

Connecting TrackRecord to Microsoft Project

Integrate TrackRecord with Microsoft Project to let managers and devel-
opment Team Member exchange up-to-date project status information
quickly and easily and link development schedules to items in the Track-
Record database. Periodically synchronizing Project information and
TrackRecord information lets you update information about project dates
and milestones, status and priorities of tasks, and the availability of
project Team Member.

Managers can track actual schedules against baseline schedules easily;
each time a Team Member marks a task as complete in TrackRecord, its
status and dates are adjusted in the project plan in Project. Similarly, a
project Team Member can use TrackRecord to obtain a list of current tasks
(which may include tasks defined in TrackRecord or Project). When a
Team Member completes an assignment, TrackRecord automatically
updates the project database and passes the new assignment information
to Project.

Integration Overview

Figure 8-3 provides an overview of the process of integrating TrackRecord
and Microsoft Project information. Each item is described fully in the
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following sections. These tasks are generally performed by a project
manager and should be done in the following order.

Figure 8-3. Microsoft Project/TrackRecord Integration Overview

Install the Microsoft Project an
TrackRecord integration macros.
See “Installing the Microsoft
Project Macros” on page 118.

Perform initial project setup to connect a
Microsoft Project-based schedule with a
TrackRecord project. See “Performing
Initial Project Setup” on page 119.

Map Project and TrackRecord
priorities. See “Mapping Track-
Record Priorities to Project Priori-
ties” on page 121.

Synchronize applications. TrackRecord
creates a new Project Task item for each
task and synchronizes status. See
“Synchronizing a Project in TrackRecord
with Microsoft Project” on page 122.

Synchronize the applications periodically, whenever you want to update
project information. Refer to “What Happens During Synchronization?”
on page 123 for an explanation of how fields are synchronized.

Installing the Microsoft Project Macros

To integrate TrackRecord and Microsoft Project information, begin by
installing the TrackRecord macros in Microsoft Project. A new Track-
Record menu will be added to the Microsoft Project tool bar.

Tip: You can enable two 1 Open the Integration.mpt file created for your specific version of
TrackRecord tool bar Microsoft Project:

buttons, one for

synchronization and the ¢ Microsoft Project 98-2000: In Windows Explorer, double-click
other for opening a task the TrackRecord Integration.mpt file to open Microsoft Project.
item, by right-clicking on By default, the file is installed in the x:\Program Files\Compu-
the Microsoft Project tool ware\TrackRecord folder where x is the drive where Windows
bar and selecting .

TrackRecord. resides on your computer.

< Microsoft Project 2002: In Windows Explorer, double-click the
trackrecord integration2002.mpt file to open Microsoft
Project. By default, the file is installed in the x:\Program
Files\Compuware\TrackRecord folder where x is the drive where
Windows resides on your computer.
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2 If the Microsoft Project Macro warning dialog box (Figure 8-4)
appears, click the Enable Macros button.

Note: This dialog box will not display if you have cleared the Always ask
before opening projects with macros check box.

Figure 8-4. Microsoft Project Dialog Box

Microsoft Project EHE

[:\Program FilesiCompuware) TrackRecord) TrackRecord Integration. mpt
contains macros.

Macros may contain viruses, It is always safe to disable macros, but if the
macros are legitimate, you might lose some Functionality.

Enable Macros | More Info |

3 Click OK.

If the Office Assistant is open, TrackRecord displays status and error
messages through the Office Assistant.

TrackRecord Menu

The integration macros create an additional TrackRecord menu in
Microsoft Project that contains three options:

¢ Synchronize Project Now — Causes TrackRecord and Microsoft
Project to exchange project information. Refer to “What Happens
During Synchronization?” on page 123 for information on what
types of information are transferred during synchronization.

¢ Open Current Item in TrackRecord - Selecting an item, such as a
task, milestone, or resource, in Microsoft Project and choosing this
option causes TrackRecord to run and open the selected item.

¢ Options - Opens a new dialog box that lets you change the user ID,
database, project, or priority map.
Performing Initial Project Setup

Before TrackRecord and Microsoft Project can exchange project informa-
tion, you must log in to TrackRecord from within Project and identify the
database and TrackRecord project associated with the current schedule.
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1 Open the Microsoft Project project file you want to use.

2 From the TrackRecord menu, choose Options. The TrackRecord
Options dialog box (Figure 8-5) appears.
Figure 8-5. TrackRecord Options Dialog Box

TrackRecord Options E

Project | it |

User: I

Database: I

Project: I LI

iSreate & Mew Braject, |

o I Cancel |

3 Enter your TrackRecord login name in the User field and the database
you want TrackRecord to use in the Database field.

4 To specify a project, do one of the following:

¢ To use an existing project, click the drop-down list in the Project
field.

¢ To create a new TrackRecord project, click the Create a New
Project button.

5 On the TrackRecord Login dialog box (Figure 8-6), enter your login
password in the Password field and click OK. Note that TrackRecord
passwords are case-sensitive.

Figure 8-6. TrackRecord Login Dialog Box

TrackRecord Login E
User: Adrmin
Databaze:  demo
Paszword: ||
O I Cancel |

6 Perform one of the following:

¢ If you are using an existing project, select it from the Project list
on the Options dialog box (Figure 8-5).
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¢ If you are creating a new project, select the check box beside the
Team Members you wish to assign to the new TrackRecord project
(Figure 8-7). Click OK when you are finished.

Figure 8-7. TrackRecord Team Member Selection Dialog Box

TrackRecord Team Member Selection E
Select the Tearn Mernbers ta add to this Project:
O Jores, Mick
O I Cancel
7 Click OK.

Mapping TrackRecord Priorities to Project Priorities

The priority assigned to a task indicates the task’s importance within a
project. When schedules grow tight, tasks with low priorities are typically
deferred or eliminated. TrackRecord and Project have different default
priority settings. Before you can use resource leveling in Project, you
must map the priority levels in TrackRecord to the corresponding priority
levels in Project. To map priorities, perform the following procedure:

1 Run Microsoft Project.

2 Open a project you have previously configured for TrackRecord and
Microsoft Project integration.

3 From Project’s TrackRecord menu, choose Options.
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4 When the TrackRecord Options dialog box appears, click the Priori-
ties tab.

Figure 8-8. TrackRecord Options Dialog Box — Priorities Tab. If your TrackRecord
administrator has modified the default priorities in TrackRecord, your Priorities tab
may differ from the one shown.

TrackRecord Options E
Project  Priorities I
Select the TrackRecord Priority that corresponds ta each MS Project Priarity:
MS Project Priarity Range TrackRecard Priarity
MS PrO]eCt — -3 £ - Suggestion . |
.. 100 - 499 4 - Low —
priority 500 - 59 2 - Marmal
. 600 - 939 2 - High Add...
settings 1000 - 1000 1- Critical
Rernae,,. |
TrackRecord
priority
settings
O I Cancel |

5 Click the Edit button to change any mapping assignments (Figure 8-
8). The Priority Mapping dialog box appears (Figure 8-9)

Figure 8-9. Priority Mapping Dialog Box

Select the range of MS Project Priarities which will be
mapped to the TrackRecord Priarity,

From: I 1000] ﬂ Through: I 1000 ﬂ

TrackRecord Priarity: I 1 - Critical j

O I Cancel |

In this example, the TrackRecord priority “1 — Critical” is mapped to
the Project priority “1000 - 1000”. Select an item from the drop-down
list to change the mappings. Click OK when your changes are
complete.

” M3 Project Priority Range

6 Click OK to close the dialog box.

Synchronizing a Project in TrackRecord with Microsoft Project

Note: Tasks are not synchronized if a Team Member has not been assigned
to the task. If you have not assigned a TrackRecord Team Member for
each task in Microsoft Project, do so now. Refer to “Performing Initial
Project Setup” on page 119 for complete instructions.
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What Happens During Synchronization?

When you choose Synchronize Project Now, TrackRecord and Microsoft
Project exchange information about Team Members, Projects, Tasks, and
Milestones in the project.

TrackRecord adds a Microsoft Project section to the bottom of the Task
item form. Selecting the Auto Update Summary field in the Microsoft
Project section of a Task item form will cause the Summary field to be
read-only in TrackRecord, allowing it to be changed through Project only.
Clearing this option allows you to change the Summary in TrackRecord,
but your changes will not be reflected in Microsoft Project.

The following tables (Table 8-2 - Table 8-5) identify what fields in Track-
Record are overwritten by information from Microsoft Project and what
fields in Microsoft Project are overwritten by information from Track-
Record.

Table 8-2. TrackRecord Team Member Item to Microsoft Project Field Mapping
MS Project

TrackRecord Team  Synchronization

Member Direction Resource Comment
Field
Name > Name Project mem-
— T - bers are defined
Initials (Abbreviation)  --> Initials in TrackRecord
Email Address > Email and sent to MS
Project.

Table 8-3. TrackRecord Project Item to Microsoft Project Field Mapping

TrackRecord Synchronization = MS Project
Project Field D){rection ProjectlFieId G
Name <-- Title Project name and
(new items only) description can be
defined in Project
Description <-- Comments and sent to Track-
(new items only) Record on first syn-
chronization.
Team Members --> Resources Team Members are
(new or changed) defined in Track-
Record.
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Table 8-4. Task Mapping
TrackRecord MS Synchronization = MS Project

Task Field Comment

Project Task Field Direction

124

Summary <-- Name Tasks are cre-
- ated in MS
Description <-- Notes Project. Com-
Assigned To <-- Resource pletion status is
. — captured in
Priority <-- Priority TrackRecord
(mapped)
Date Due <-- Finish (base- In order for this
line) field to be
imported, there
must be a base-
line assigned
Date Completed --> Finish (actual) Tasks are cre-
. o ated in MS
Completed > % Complete Project. Com-
Identifier (autogener-  --> WBS field pletion status is
ated) captured in
TrackRecord

TrackRecord

Milestone Field

Synchronization
Direction

MS Project
Task Field

Table 8-5. TrackRecord Milestone Item to Microsoft Project Task Field Mapping

Comment

Name <-- Name Milestones and
I planned dates
Description <-- Notes are defined in
Project <-- Associated MS Project.
Project Actual dates are
captured in
TrackRecord
Projected End Date <-- Finish (base- In order for this
line) field to be

imported, there
must be a base-
line assigned
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Table 8-5. TrackRecord Milestone Item to Microsoft Project Task Field Mapping

TrackRecord Synchronization = MS Project

Milestone Field Direction Task Field Sement
Start Date -> Project Start Milestones and
date planned dates
.- are defined in
Actual End Date -> Finish (actual) MS Project.
Actual dates are
captured in
TrackRecord

Performing Project Synchronization

1 Open the Microsoft Project file for the project you want to synchro-
nize.

2 From Project’s TrackRecord menu, choose Synchronize Project
Now.

3 If you have not already done so, you will be prompted to login into
the TrackRecord database. The TrackRecord Synchronization dialog
box indicates the progress as TrackRecord and Project exchange infor-
mation.

4 When the TrackRecord Synchronization Complete dialog box
appears, click OK.

Integrating TrackRecord With Visual Basic

Visual Basic is a programming environment from Microsoft in which a
programmer uses a graphical user interface to choose and modify prese-
lected sections of code written in the BASIC programming language. You
can integrate TrackRecord with Visual Basic to allow you to submit a
defect or task into the TrackRecord database from within Visual Basic.

Required: TrackRecord must be installed after Visual Basic in order for the
integration to work. If you installed TrackRecord first, you must
uninstall and reinstall the product before performing these proce-
dures.
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Enabling Visual Basic Integration

1 From Visual Basic’s Add-Ins menu, select Add-In Manager. The Add-
In Manager dialog box appears.

2 From the list of available add-ins, select Compuware TrackRecord.

3 Ensure that the Loaded/Unloaded and Load on Startup check boxes
are selected.

4 Click OK to exit the dialog box.

Disabling Visual Basic Integration

1 From Visual Basic’s Add-Ins menu, select Add-In Manager. The Add-
In Manager dialog box appears.

2 From the list of available add-ins, select Compuware TrackRecord.

3 Ensure that the Loaded/Unloaded and Load on Startup check boxes
are cleared.

4 Click OK to exit the dialog box.

Logging Into TrackRecord From Visual Basic

Log into TrackRecord from Visual Basic by performing the following
procedure:

1 From Visual Basic’s TrackRecord menu, choose Change Login.
2 On the TrackRecord Login dialog box,

¢ Enter your TrackRecord login name and password. Note that they
may be different from your Windows login name and password.
Passwords are case-sensitive.

¢ Identify the database you want TrackRecord to use in the Data-
base field by selecting a name from the drop-down list or by
entering a new name.

If you have used TrackRecord before, the names of the databases
you have used previously appear in the Databases list. You do
not need to enter the path to the database, just the database
name.

& Click OK.

Submitting a Defect

To enter a defect into the TrackRecord database from within Visual Basic,
simply perform the following procedure:
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1 Ensure that you are logged into TrackRecord from Visual Basic. See
“Logging Into TrackRecord From Visual Basic” on page 126.

2 From Visual Basic’s TrackRecord menu, choose Submit Defect. The
TrackRecord Defect Item appears.

3 Enter information into the applicable fields. For more information
on using TrackRecord forms, refer to Chapter 3, “Entering and Edit-
ing Data”.

4 Click Save and Close when you are finished.

Submitting a Task

To enter a task into the TrackRecord database from within Visual Basic,
simply perform the following procedure:

1 Ensure that you are logged into TrackRecord from Visual Basic. See
“Logging Into TrackRecord From Visual Basic” on page 126.

2 From Visual Basic’s TrackRecord menu, choose Submit Task. The
TrackRecord Task Item appears.

3 Enter information into the applicable fields. For more information
on using TrackRecord forms, refer to Chapter 3, “Entering and Edit-
ing Data”.

4  Click Save and Close when you are finished.

Using TrackRecord With Visual C++

Nearly all world-class software, from the leading Web Browsers to
mission-critical corporate applications, is built using the Microsoft Visual
C++ development system. Visual C++ is the most productive tool for the
highest-performance development for Windows and the Web. You can
integrate TrackRecord with Visual C++ to allow you to submit a defect or
task into the TrackRecord database from within Visual C++.

Required: TrackRecord must be installed after Visual C++ in order for the
integration to work. If you installed TrackRecord first, you must
uninstall and reinstall the product before performing these proce-
dures.
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Enabling Visual C++ Integration

1

4

From Visual C++’s Tools menu, choose Customize. The Customize
dialog box appears.

Click the Add-ins and Macro Files tab.

From the list of available add-ins and macro files, select TRDevStu-
Addin. TRDSAddin.

Click the Close button to exit the dialog box.

Disabling Visual C++ Integration

1

4

From Visual C++’s Tools menu, choose Customize. The Customize
dialog box appears.

Click the Add-ins and Macro Files tab.

From the list of available add-ins and macro files, clear the TRDevS-
tuAddin. TRDSAddin option.

Click the Close button to exit the dialog box.

Submitting a Defect

To enter a defect into the TrackRecord database from within Visual C++,
simply perform the following procedure:

_—

.4
L%

2
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Click the Submit Defect icon on the Visual C++ tool bar. If the icon is
not visible, follow the steps for “Enabling Visual C++ Integration” on
page 128.

On the TrackRecord Login dialog box,

¢ Enter your TrackRecord login name and password. Note that they
may be different from your Windows login name and password.
Passwords are case-sensitive.

¢ Identify the database you want TrackRecord to use in the Data-
base field by selecting a name from the drop-down list or by
entering a new name.

If you have used TrackRecord before, the names of the databases
you have used previously appear in the Databases list. You do
not need to enter the path to the database, just the database
name.

& Click OK.



3 The TrackRecord Defect Item appears. Enter information into the
applicable fields. For more information on using TrackRecord forms,
refer to Chapter 3, “Entering and Editing Data”.

4 Click Save and Close when you are finished.

Submitting a Task

To enter a task into the TrackRecord database from within Visual C++,
simply perform the following procedure:

1 Click the Submit Task icon on the Visual C++ tool bar. If the icon is
” X not visible, follow the steps for “Enabling Visual C++ Integration” on
o page 128.

2 On the TrackRecord Login dialog box,

¢ Enter your TrackRecord login name and password. Note that they
may be different from your Windows login name and password.
Passwords are case-sensitive.

¢ Identify the database you want TrackRecord to use in the Data-
base field by selecting a name from the drop-down list or by
entering a new name.

If you have used TrackRecord before, the names of the databases
you have used previously appear in the Databases list. You do
not need to enter the path to the database, just the database
name.

& Click OK.

3 The TrackRecord Task Item appears. Enter information into the appli-
cable fields. For more information on using TrackRecord forms, refer
to Chapter 3, “Entering and Editing Data”.

4  Click Save and Close when you are finished.

Utilizing TrackRecord with Version Control Systems

Version control system (VCS) applications help you manage projects by
controlling and tracking source and other project files. You can integrate
TrackRecord with VCS applications, such as Microsoft Visual SourceSafe,
Merant PVCS, and MKS Source Integrity. Integrating TrackRecord with a
version control system allows you to check files in and out from within
TrackRecord, open read-only versions of source files, and synchronize
releases with VCS labels.
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Required: TrackRecord must be installed after VCS in order for the integra-
tion to work. If you installed TrackRecord first, you must uninstall
and reinstall the product before performing these procedures.

When you integrate TrackRecord with a VCS application, each tool tracks
parallel sets of changes to your software projects. TrackRecord tracks
change requests and their resolution, such as defects that have been fixed
or features that have been added. A VCS application tracks changes to
files. By integrating the tools, you can identify which source file changes
were associated with specific change requests.

For example, a developer fixing a defect checks out source files, makes
changes to them, and checks them in again. If a problem with the defect
fix is subsequently identified, you can use the VCS files to identify and
roll back the files that were modified, making it easier to resolve the
problem.

For each file, release, and project in a VCS application, TrackRecord
maintains a corresponding item in the database. This item references the
source file. In most situations, the program creates items automatically
when you check files in or out. However, you must update information
for milestones, projects, and for file items that already exist in Track-
Record.

Associating a TrackRecord Project with a VCS Project

To associate a TrackRecord project with a VCS project, perform the
following procedure:

1T Open a new or existing project in TrackRecord.

¢ To open a new project, choose File>SNew>Other. From the
Choose a Type dialog box, select Project and click the New but-
ton.

¢ To open an existing project, choose File>Open>Other. From the
Item Browser, select Project and double-click the appropriate
project name in the Items list.
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2 When the Project form appears, click the button beside the VCS
Project Name field (Figure 8-10).

Figure 8-10. VCS Button Location

B Project Item - Fault Manager [_[O] %]
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Description: -~

Click the VCS Code moddlator] |
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version 4 Project Name:
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Contro Current Yersion: Current Build Wumber:
! |

system. s *5
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Note: For additional information on associating a TrackRecord Project to a
VCS Project, consult your VCS documentation.

If you do not already have Source File and Data File items that you want
to connect with your VCS files, TrackRecord will automatically create
these items the first time you check the file in or out from within Track-
Record. When the items are created, you will see a status message, and
have the opportunity to enter a description of the new file.

Checking Files In and Out

You typically check source files in and out of a VCS system in the course
of working on a specific TrackRecord Defect or Feature. When you check
files in and out of a VCS system from within TrackRecord, TrackRecord
automatically records the file name and current VCS version number in
the item’s change history. To check a file in or out from TrackRecord,
execute the following steps:

1 Open the appropriate Defect or Feature item.

2 Verify that the project identified in the Project field is associated
with a project in your VCS application.

3 From TrackRecord’s Edit menu, choose Source Control>Check Out
or Check In.

Note: If the submenus of the Edit>Source Control menu are disabled,
ensure that the type contains a field that is associated to the type
Source File and you have a VCS login and password. For more
information on types, refer to the TrackRecord Administrator’s
Guide.
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You will be presented with a list of files from your VCS project, which
can be checked in or out as appropriate.

When the file(s) are checked in, TrackRecord copies the descriptive
comments from the Resolution Details field to the VCS Comment
field. This comment may then be further modified as desired.

Synchronizing TrackRecord and VCS Projects

Tip: If TrackRecord
cannot find the VCS
project, verify that the
Release item is contained
in a Project item that
contains a valid VCS
Project field. To add the
release to the Project,
open the Project item,
scroll to the Builds/
Releases field, and click
Add Item. After the
Release item links to the
Project item, you should
be able to display the list
of your VCS labels.

Labels are user-defined identifiers used by VCS applications to represent a
specific version of a project or file. When you label a project, all the files
in that project inherit the label. For example, if you assign a label of
“Beta 1” to a project, you can retrieve the appropriate version of files
within that project by using the project label.

Connecting your TrackRecord releases with your VCS releases works the
same way as connections to projects and file names, with one exception:
you can create a new VCS label from within TrackRecord, at the same
time you create a TrackRecord release.

Associating a TrackRecord Release with a VCS Label

Perform the following procedure to associate a TrackRecord release with a
VCS label:

1 Open the Item Browser.
Select the Show All check box.
Select Release from the Types list.

A W N

From the Items list, select the release you wish to associate with a
VCS label.

5 Click the button beside the VCS Release>Label field. TrackRecord
displays a list of your VCS labels.

6 To use an existing label, select the appropriate entry in the list. To
create a new label from within TrackRecord, click the New button.

To create a new VCS label from within TrackRecord, select the check
box next to the VCS Release field, and click the New button. Track-
Record will use the name of the release as the default value for the
label; you can change this value when prompted for the release
name. When TrackRecord creates the release, it applies the label to
the entire project associated with the Release item.

7 Click OK.

132 TrackRecord User’s Guide



Troubleshooting

For a detailed listing of troubleshooting and configuration information
for one of the supported version control systems, refer to “Troubleshoot-
ing” in the TrackRecord online help or the Release Notes.

For the most current TrackRecord support information, please visit the
Compuware Web site at: http://www.compuware.com. From this
location, you will have access to our online Knowledgebase and the most
current patches and updates for the product.

Integrating TrackRecord With Compuware Products

TrackRecord integrates with four of Compuware’s product families:
QACenter, DevPartner Studio, Vantage, and Abend-AID.

Using TrackRecord With QACenter

The Compuware QACenter product family offers sophisticated
automated testing tools for mainframe, client/server and Web develop-
ment projects.

TrackRecord can capture and track defects identified with these tools and
manage the resolution process. TrackRecord currently integrates with
QACenter’s Reconcile, TestPartner, and QADirector. This integration does
not require configuration because when run in the same development
environment, TrackRecord and QACenter can share a single project
database. Defects entered through QADirector, TestPartner, or Reconcile
can become a part of TrackRecord Milestone Status reports or Outline
Reports.
Note: Refer to the Reconcile, TestPartner, or QADirector documentation for
general information on using these products.

Reconcile

TrackRecord's integration with Compuware's requirements management

tool, Reconcile, provides pertinent reporting information to help manag-

ers better understand project status. Reconcile can track the status of a

requirement’s associated defects, and can keep TrackRecord updated on

the status of requirements. This exchange of information permits cross-

product reporting and analysis. Reconcile also is used to:

¢ capture and manage business, technical, and testing requirements

& track the source of each requirement along with its priority and sta-
tus

¢ correlate open issues to original requirements
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QADirector

Integration between TrackRecord and QADirector incorporates defect
tracking easily into the automated testing process. Testers can report,
prioritize, and assign defects quickly; the development team receives the
detailed information needed to reproduce and resolve the problem.

Note: Refer to the TrackRecord Administrator’s Guide for information on
integrating a customized TrackRecord database with QADirector.

QADirector provides a menu for submitting defects directly to Track-
Record and for viewing submitted defects from within QADirector. For
example, if a failed QADirector test reveals a defect in the application,
you can submit the defect to TrackRecord from QADirector, and it will
automatically enter relevant information about the failed test in the new
Defect item.

TrackRecord includes a QACenter Reported Defect item that is specifically
designed for logging defects reported by its testing tools. The QACenter
Reported Defect item contains all the fields found in its parent type,
Defect, plus additional QACenter-specific fields such as Test Tool, Script
Name, and Failure Reason. If your testing reveals a defect in the test
application, you can use the QACenter Reported Defect item to record
the test, tool, and diagnostic information so that the problem can be re-
created and fixed.

TestPartner

Use TestPartner in conjunction with TrackRecord to track bugs in your
test application. For example, if a failed TestPartner test reveals a defect in
the application, you can submit the defect right from TrackRecord.
TestPartner automatically enters relevant test information in the Track-
Record defect item, reducing the amount of required data entry. The
failed test is linked to the TrackRecord defect by means of a defect ID.

Using TrackRecord With DevPartner Studio

134

TrackRecord is part of the DevPartner Studio Enterprise Edition (DPSEE)
suite of software debugging tools for building components and applica-
tions using Microsoft Visual Studio and Java. TrackRecord is the integra-
tion core of the DPSEE suite of automated tools for error detection,
performance tuning, and testing coverage. TrackRecord serves as a central
repository and communication hub for all development-related activities
and data. It automatically captures information generated by the DPSEE
developer tools including:

Note: Refer to the DevPartner Studio Enterprise Edition documentation for
general information on using these products.
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¢ a comprehensive milestone report of development and testing status

¢ detailed information about the detection, diagnosis, and resolution
of software problems

¢ platform hardware and software configuration data

consolidated or filtered test coverage data, which reveals untested
software by platform, user, or configuration

code volatility information
defects and issues including the software build

task and defect lists for each developer

* ¢ o6 o

testing, profiling, and automated error-detection status of each
project

TrackRecord’s ActiveLink feature submits information generated by
DevPartner Studio tools directly to a TrackRecord project database. The
project database is accessible to developers from within the DevPartner
Studio tool such as BoundsChecker or TrueTime, and from within Visual
Studio. TrackRecord compares new defect submissions against existing
issues to reduce duplicate defect entries. This integration provides users
with the information they need from within the tools they use.

Note: Integration of TrackRecord and the DevPartner Studio tools is version
dependent. You many need to upgrade your TrackRecord or DevPart-
ner Studio software if you purchased the tools at separate times.

TrackRecord can literally track anything. These features are just a limited
glimpse of what TrackRecord can do in conjunction with the following
DPS tools:

¢ BoundsChecker— Delivers automatic error detection for C/C++/
VC++. Once a runtime error has been found by BoundsChecker, it
can be automatically entered into TrackRecord.

¢ SmartCheck— Delivers automatic error detection for Visual Basic.
Once a runtime error has been found by SmartCheck, it can be auto-
matically entered into TrackRecord.

¢ JCheck— Provides automatic error detection for Java. Once a runt-
ime error has been found by JCheck, it can be automatically entered
into TrackRecord.

¢ CodeReview— A static source code analysis tool for Visual Basic.
Once an error has been found by CodeReview, it can be automatically
entered into TrackRecord.
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¢ TrueTime— A performance analysis tool for VB/C/C++/VC++/Java/
ASP. Once a performance error has been found by TrueTime, it can be
automatically entered into TrackRecord.

¢ Memory Profiler— A memory analysis tool for Java. Once a memory
issue has been identified by Memory Profiler, it can be automatically
entered into TrackRecord.

¢ FailSafe— An automatic error handling tool for Visual Basic. If an
application has been instrumented with FailSafe, it can email the
error back to TrackRecord from a remote location to ensure that an
error does not go unreported in production.

DevPartner Studio Interaction with TrackRecord

DevPartner Studio Enterprise Edition derives much of its power from its

underlying ActiveLink connection to TrackRecord. ActiveLink automates

the submission of debugging/tuning tool information to a database. This
accumulated information provides:

¢ Platform configuration data, including hardware resources and ver-
sion information about installed software components

Coverage data gathered from all developers using TrueCoverage
Code volatility information
Build matching to registered builds

Task lists for each developer

® & 6 o o

Detailed error messages from the error detection tools

Logging In to TrackRecord from DevPartner Studio Tools

When starting a DevPartner Studio tool, you are prompted to log in to a
TrackRecord database. Logging in at this time does not start TrackRecord,
but allows access to tasks and defects within the database.

If you are already logged in to TrackRecord, you can change your login
identity from within any of the DevPartner tools.

To log in to a TrackRecord database, perform the following procedure:
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1 From the DevPartner tool’s TrackRecord menu, select Change Login
(Figure 8-11).

Figure 8-11. Changing TrackRecord Login from Within JCheck

File Edit “iew Project EEEEASEGN indow Help

= | 5 || Submit MeyEartnen Fepated efest.

Stk MevEartner Tashk..

LI Open Tasgk List...

% o | Change Login...
2 In the TrackRecord Login dialog box:

¢ Enter your login name in the Name field.

¢ Enter your login password in the Password field. Passwords are
case-sensitive.

¢ Identify the database you want to use in the Database field. The
names of the databases you have used recently appear in the
Databases list. You can select the database you want to use from
this list or enter a different database name.

3 Click OK.

Automated Session Submission

TrackRecord logs DevPartner Studio developer tool session information
against a specific project build. Most development teams will appoint a
single person to manage the build creation process.

A Project item includes a field for the Current Build Number (Figure 8-
12). This field designates a number for the build registration utility to use
as a starting value when constructing build names. Build Registration
creates a build name that usually includes an incrementing build number
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to identify a specific software build, along with the executable compo-
nents that define that build.

Figure 8-12. Project Item'’s Current Build Number Field

& Project Item - =|o]x
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.......................

Current Build Number Field

Software developers cannot submit debug tool sessions from DevPartner
tools, such as BoundsChecker and TrueCoverage, to the TrackRecord
database without a registered build, which is done using the Build Regis-
tration utility. A configuration administrator must create at least an
initial build against which developers can submit debugging informa-
tion.

Software development groups with multiple developers usually create an
automated build process to construct their applications. This automated
process could use, for example, MS-DOS batch files to call Make utilities
that automate compiler operation and place files in specified locations.

Administrators can make TrackRecord build registration a part of this
automated build process. Automating build registration ensures that a
build gets registered at the time the build completes.
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Registering a Single
Build Using the Build
Registration Utility

1

Click the task bar’s Start button and choose Build Registration from
the TrackRecord program files. The Build Registration Utility appears
(Figure 8-13).

Figure 8-13. Build Registration Utility

!‘, TrackRecord Build Registration Utility

The TrackRecord Build Registration Ukility lets you submit information about builds o TrackRecord,

This will allows any TrackRecord user to submit sessions run on those builds, and will allow TrackRecord to
automatically pre-fill the build identifier in bug reports submitted from sessions run on those builds,

Project:  |Beta 1 j

Builds submitted For this project:

ame | Submitked | 1

Edlit.

[Eleter ..

L

Refresh

—Automatic build name generation
¥ Enabled

Exit | Help

Select a project from the Project drop-down list. Click the Edit but-
ton if you want to modify the default formula for constructing build
names.

Click the New button. The Submit Build Information for <Project-
name> dialog box appears (Figure 8-14).

Figure 8-14. Submitting Build Information

Submit Build Information for “Beta 1*

Build Mame: Beta 1 Build #1: 7/31/01 2:26 PM

TrackRecord will use the name, date, and version information of the executable files specified below
to match sessions ko this build,

Mame | Size | Modified | Linked
cwaftrosry, exe 53KE 7/18/01 10:20 AM FiEi01 10:20 AM
Remove
| | 0|
Submit Cancel | Help
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4 Click the Add button. The Add Executable Files to <Buildname> dia-
log box appears and displays directory and file information.

5 Choose the EXE, DLL, and OCX files that compose this build.

These components include the executable components that your
developers are building for this project.

6 Click the Add button.
7 Click the Submit button and then click Exit.

[¢]

Automating Build Open your development groups build automation script in a file edi-
Registration tor.

9 Type a line to run the command-line version of the build registration
utility, BUILDNEW.EXE (use the /? switch to view the options and syn-
tax of this command).

For example, type the lines:
buildnew /P”Wildfire” /U”Joe Developer,mypasswd”
c:\Wildfire\Release\*.exe
buildnew /P”Wildfire” /U”Joe Developer,mypasswd” /A
c:\Wildfire\Release\*.d11
A variation of this syntax uses a file name in place of a list of compo-
nents:
buildnew /P”Wildfire” /U”Joe Developer,mypasswd”
@wildfire.bld
Here, the file WILDFIRE.BLD contains the paths, individual files
names, or wildcard references to the executable components you
want to include in the registered build.

10 Save the file.

Platform Configuration

When an application runs under one of the DevPartner tools, Track-
Record records hardware and software configuration information about
the computer on which the tested application executes. The hardware
configuration information is stored in an item called Hardware Configu-
ration and is associated to the defect or session via the Defect’s Configu-
ration field. Software configuration information is stored as a list of
Executable File objects in a Defect or TrackRecord Session item’s Loaded
Components field.

The Configuration type contains fields for information such as the type
of processor, amount of memory, screen resolution, and the operating
system.
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Viewing Captured
Platform
Configuration Data

Viewing Sessions on
Hosts Using Specific
Components

A Loaded Components field in an item tracks the details of DLL, OCX,
and the EXE files used by the application being debugged. These details
include the link date and time and version resource strings. Many
software vendors, including Compuware and Microsoft, use version
resource strings to provide unique version numbers of components.

Platform configuration information, including software component
version numbers, can aid the process of finding errors caused by compo-
nent incompatibility.

Suppose a tester reports a defect, but a developer cannot duplicate the
defect. One cause for discrepancies of this nature is mismatched versions
of essential software components, such as dynamic link libraries and
ActiveX custom controls. TrackRecord’s Advanced Search capability gives
Team Member one tool for uncovering such discrepancies.

To view sessions on hosts that use a specific component, perform the
following procedure:

1 From the TrackRecord Tools menu, choose Advanced Search. The
Choose a Type dialog box appears (Figure 8-15).

Figure 8-15. Choose a Type Dialog Box
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Customer
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Project
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Close I Help |

2 Select DevPartner Session and click the Search button to open the
DevPartner Session Item Search dialog box.

3 Double-click the Loaded Components field. The Item Browser dis-
plays a list of Application Component items.

4 Select the component from the Application Component list and
click OK.

5 Click the Search button on the DevPartner Session Item Search dia-
log box toolbar to open the Search Results dialog box.

6 Select any listed item and click the Open button.
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7 Click Close and Cancel.

Troubleshooting TrackRecord and DevPartner Integration

For troubleshooting documentation, refer to “Troubleshooting” in the
TrackRecord online help or the Release Notes.

For the most current TrackRecord support information, please visit the
Compuware Web site at: http://www.compuware.com. From this
location, you will have access to our online Knowledgebase and the most
current patches and updates for the product.

Using TrackRecord With ClientVantage

TrackRecord integrates with Compuware’s Vantage tools. ClientVantage,
a program designed to measure application performance and availability
to maintain high service levels.

TrackRecord can integrate with ClientVantage’s Fault Detection to
include captured fault data as part of a defect report automatically.

Note: Refer to the ClientVantage documentation for general information on
using this product.

Using TrackRecord With Abend-AID
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TrackRecord can be used with Abend-AID products to automate fault
management and reduce critical application downtime. TrackRecord
automates key areas of the problem-resolution process: notification,
prioritization, workgroup communications, resource management, and
reporting.

For example, Abend-AID Fault Manager can automatically load fault
information into a TrackRecord database, reducing the amount of
required data entry. TrackRecord then enables you to: assign fault
notices, track and report on the status of faults, add information to faults,
and create graphical reports. The online access to reports and graphs
contains information such as:

¢ current defects

¢ high priority defects by application, developer, and date

¢ defects fixed-by version, programmer, priority, date or any set of cate-
gories desired

¢ defect statistics and trends

With Abend-AID Fault Manager, you can:

¢ respond to application failures immediately
¢ report on service level agreements
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¢ manage and justify resources
¢ improve application quality
¢ perform trend analysis

Note: Refer to the Abend-AID documentation for general information on
using this product.
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Glossary

Abend-AID Fault Manager: An automated fault management tool to help IT managers reduce
downtime and optimize resources. Provides real-time and historical reports and graphs for
monitoring the fault resolution process.

abbreviation: Text used to identify an item in the TrackRecord database.

absolute date: Entry in a date field that identifies a specific date; for example, May 19, 1999 or 2/
14/87. Compare relative date.

access control: Function of an application that restricts user access to data according to permissions
derived from the user’s identity or membership in groups.

Activelink tags: A mechanism to allow administrators to link the types and fields they create with
the underlying structure.

ActiveX control: An interface object on a form that enables or enhances a user’s interaction with an
application. ActiveX controls have an .ocx file name extension.

administrator: The person responsible for installing, configuring, and maintaining TrackRecord
user accounts. The TrackRecord administrator may or may not be responsible for maintaining the
network and database for a site.

API: An application program interface (API) is the specific method used by a computer operating
system or by another application program by which a programmer writing an application program
can make requests of the operating system or another application.

ASCII file: American Standard Code for Information Interchange (pronounced ASK-ee). Code in
which numbers from O to 255 represent individual characters, such as letters, numbers, and
punctuation marks. Standard for text representation.

audit trail: Record identifying each change made to an item or report and the identity of the person
making the change. See change history.

AutoAlert: An optional component that provides email notification to users of the defects that
pertain to them.
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AutoAlert Administration Utility: A tool that allows you to add and remove databases that are being
polled by the AutoAlert service, show users that have AutoAlert enabled, and set a variety of
AutoAlert options.

available states: The Workflow Editor’s list of states that have been defined, but are not yet used in
the workflow.

bug report: See defect.
calendar: TrackRecord automatically displays a list of appointments and tasks.

CGl request: Common gateway interface (CGI) is a standard way for a Web server to pass a Web
user's request to an application program and to receive data back to forward to the user. For
example, when a user fills out a form on a Web page and sends it in, it usually needs to be
processed by an application program. The Web server typically passes the form information to a
small application program that processes the data and may send back a confirmation message.
This method or convention for passing data back and forth between the server and the application
is called the common gateway interface (CGI). It is part of the Web's Hypertext Transfer Protocol
(HTTP).

change history: Record identifying each change made to an item or report and the identity of the
person making the change. See audit trail.

child: An item that is subordinate to another item.

child header: A header that is subordinate to another header within an Outline Report. In the
following example, Open Bugs is a child header of Bugs, and Priority 1 is a child header of Open
Bugs. Compare parent header, sibling header.

Bugs

Open Bugs

Priority 1

Priority 2

Closed Bugs

ClientVantage: Formally known as Interval Pro, ClientVantage is designed to validate end-user
response time from the end-user perspective and proactively measure application performance and
availability to maintain high service levels.

cloning projects: Duplicating and reusing information from existing projects.

Command Line Interface: A CLI (command line interface) is a user interface to a computer's operat-
ing system or an application in which the user responds to a visual prompt by typing in a
command on a specified line, receives a response back from the system, and then enters another
command, and so forth.

coverage: Percentage of a project that has been tested, expressed as a percentage of lines tested or a
percentage of the functions tested.

data type inheritance: TrackRecord uses a data hierarchy to develop related data types. When one
data type (the child) is based on another data type (the parent), the child type inherits all the fields
and controls of the parent type. See child and parent for more information.
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database: A collection of data that is organized so that its contents can easily be accessed,
managed, and updated. TrackRecord uses a relational database, a tabular database in which data is
defined so that it can be reorganized and accessed in a number of different ways.

database lock-out: A error that will result if attempting to change the database (usually by creating
or modifying types) while in use. A dialog will appear listing current users to allow the administra-
tor to advise them to log off.

DBHost: Database Host. It caches values for a specific database.

defect: Report describing a problem found with software or hardware undergoing testing. A defect
report is updated over time as a problem is reported, reproduced, fixed, and tested.

Defect: Item in the TrackRecord database describing a specific problem identified during project
testing.

derived type: A data type that inherits all of the fields of its parent’s type. For example, a Software
User object inherits all the fields from the Person data type.

DevPartner Studio: TrackRecord is part of the Compuware DevPartner Studio suite of Windows-
based, software debugging tools. Easily integrated into every team’s development process, includ-
ing Web-enabled, e-commerce, and distributed applications to help developers automatically
detect, diagnose, and facilitate resolution of software errors; maximize code performance; and
ensure optimum code coverage and testing.

export: To generate a formatted file containing data from the TrackRecord database for use by
another application.

Fault Manager: See Abend-AID Fault Manager.

favorite reports: Frequently used reports or views.

fields: Holds specific facts about an item, such as a person’s address or the name of a project.
filter: Process that selects information from the database according to user-specified criteria.

function coverage: A measure of how much of the code for a project has been tested, expressed as a
percentage of functions tested across all TrueCoverage sessions relative to the total number of
functions in a project.

global favorite types: Favorite types that are shared with every TrackRecord user.
global Outline Report: Outline Reports that are shared with every TrackRecord user.

Global Preferences Administration: Creating queries, reports, and global templates, and identifying
Home Pages and favorites for all users.

global query: Queries that are shared with every TrackRecord user.
global template: Templates that are shared with every TrackRecord user.
graph: A visual summary of information.

Group Administration: Creating groups and establishing group access rights.
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header: Entry in an outline report that corresponds to a database query.

Header Wizard: TrackRecord utility that simplifies the process of defining and formatting outline
reports. The Header Wizard was called the Header Engineer in previous TrackRecord releases.

hide: A field-level privilege setting that allows making a field invisible on a group-by-group basis.

Home Page: A report that opens automatically when TrackRecord is launched and can be accessed
through the Home Page button.

import: To bring data generated by another application into the TrackRecord database.
inheritance: Property of data types that allow them to derive their structures from parent types.

item: Object or entity of a specific type in the TrackRecord database. Equivalent to a record in a
relational database.

Item Browser: Provides access to information in the TrackRecord database and allows the creation
of new items.

label: User-defined name you can attach to a specific software release or build in version control
systems.

line coverage: A measure of how much of the code for a project has been tested, expressed as a
percentage of code lines tested across all TrueCoverage sessions relative to the total number of code
lines in a project.

link: Relationship between items in the TrackRecord database. A link is created whenever one item
references another. For example, attaching a note to a Person object creates a link between the two
items.

mail query: A TrackRecord query in which an option is enabled to email users when new items
match the query.

menu bar: Displays on the TrackRecord user interface below the window title and contains the
following menus: File, Edit, Administrator, Favorites, Tools, Window, and Help.

merging: The process of compiling coverage information across multiple test sessions.

milestone: An event or point in a schedule that marks the transition of a project from one phase to
another.

Milestone Status: Report that identifies the current status of a project with respect to a specified
milestone, the volatility of a project from one build to another, data submitted from DevCenter or
QACenter tools, and custom queries that summarize project information.

OLE-compliant: A set of APIs to create and display a document, OLE (Object Linking and Embed-
ding) is Microsoft's framework for a compound document technology. Part of Microsoft's ActiveX
technologies, OLE is part of a larger, more general concept, the Component Object Model.

Outline Report: Structured view of information in the TrackRecord database that is updated dynam-
ically.

parent: An item that has one or more subordinate items.
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parent header: A header that owns one or more subordinate headers within an outline report. In
the following example, Bugs is the parent header of Open Bugs, and Open Bugs is the parent
header of Priority 1 and Priority 2. Compare sibling header, child header.

Bugs

Open Bugs

Priority 1

Priority 2

Closed Bugs

password: Text string used to verify the identity of a user before granting the user read or write
access to TrackRecord information.

priority: Arbitrary integer value assigned to a defect to indicate its significance relative to other
defects. Depending on the standards of your site, you can use a higher or lower number to indicate
that one defect is more important than another.

Project Administration: Determines the organizational framework for completing a deliverable
including tasks required to build an application, people who work on those tasks, and dates on
which the tasks must finish.

QADirector: QADirector is a powerful, extensible test management solution for full life cycle
testing of distributed large-scale applications.

query: A means to specify criteria for data retrieval.

Reconcile: An enterprise-wide requirement management system. It allows a project team to create,
change, track, and report on project requirements.

recurring events: Event scheduled to occur at regular intervals, such as Every Thursday.

relative date: Entry in a date field that identifies a date relative to the current system date; for
example, Yesterday or Tomorrow. Compare absolute date.

Remainder Header: A None of the Above summary item used in an Outline Report. It is typically
used to identify items belonging to a parent header that fail to match all criteria.

Rich Text Format (RTF): A file format that lets you exchange a text file between different word
processors and different operating systems.

right-click: Pressing and releasing the right mouse button while positioning the cursor over an
object or control on the screen. Typically opens a shortcut menu, which displays options applica-
ble to the control or item over which the cursor is positioned.

share groups: Groups whose members share queries, Outline Reports, Milestone Status views, and
templates.

shared: Property of a report that allows TrackRecord users other than the report’s owner to view it.
Only the owner of a report can modify a shared report, though other users can copy it (by saving it
under a new name) and then modify their copy.

shortcut menu: Menu that appears when you right-click a control or item in a window.
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sibling header: A header that is at the same level as another header within an outline report. In the
following example, Open Bugs is a sibling header of Closed Bugs, and Priority 1 is a sibling header
of Priority 2. Compare parent header, child header.

Bugs

Open Bugs
Priority 1
Priority 2
Closed Bugs

status bar: Located at the bottom left of the screen, this bar provides suggestions for the actions
you can perform with a tool or a selected object.

subproject: A project that is one component of a larger or more complex project.
task: Any activity in a project that has a beginning date and an end date.

Task: An item in the TrackRecord database that identifies a task in a project.
Team Member: An individual assigned to work on a project.

template: A document or file having a preset format, used as a starting point for a particular appli-
cation so that the format does not have to be recreated each time it is used.

TestPartner: An automated functional testing tool that has been specially designed for testing
complex applications based on Microsoft, Java and Web based technologies.

toolbar: Contains shortcuts to the most commonly used tasks such as creating a new item or view,
opening an existing item, displaying the Item Browser, opening the Home Page, or searching.

transient sessions: Efficient data structures that cache data from users for a period of ten minutes
before it is removed.

type: An organizational system that provides the framework on which the TrackRecord database is
built. Information is organized into categories such as Person, Company, Defect, or Project.

Type Editor: Inserts fields into a form, modifies fields on a form, and modifies settings.
type inheritance: See data type inheritance.

version control system (VCS): An application that maintains multiple versions of source files,
controls who can read and update source files, and records information about changes to source
files.

views: A specification for how data is displayed.
visible group layers: A list of all defined groups in the Workflow Editor.

volatility: A measure of the stability of code from one build to another, expressed as a percentage of
the functions that changed between two builds.

WebMonitor: A monitoring component that maintains all currently active users sessions.

WebServer: An optional component that allows access to the TrackRecord database through a Web
browser.
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work area: Area where the workflow is created in the Workflow Editor.
workflow: A series of actions and the states resulting from these actions.

Workflow Editor: Creates and modifies the workflow and consists of these frames: available states,
visible group layers, and work area.
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templates for creating items in 103

using headers 63

using queries 57
Outlook, integration with TrackRecord 113
Overview

of database concepts 15

of integration with Microsoft Project 117

of process 13

of product 11

P

Parent types 17

Parent, definition of 148
Parent/child relationships 17
Password 20, 21, 126, 128, 129, 149
Pie graphs 71

Platform configuration, with DevPartner tools

140
Popup frames in online help 27
Preferences 29
Preserving window layout 30
Printing
from the WebServer 94
online books 8
Outline Reports 60, 69
Priorities, in Microsoft Project 121
Priority, definition of 149
Process overview 13
Product enhancements 7
Product integration 11
Project
administration 149
associating TrackRecord with VCS 130
definition of cloning 146
displaying list of labels 132
see also Microsoft Project 117
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synchronizing TrackRecord and Microsoft §

Project 125 Save options 42
Search tool, hiding 24
Search, on Toolbar 24
Searching
Q advanced 28
QACenter, integration with TrackRecord 133 for data 27
QADirector for data using queries 45
defined 149 simple 27
integration with 133 using an AND specification 47
Query using an OR specification 47
composition guidelines 46 with WebServer 97
creating 50 Server name 25
creating AND specification 47 Sessions
creating OR specification 47 automatic submission 31
defined 45, 149 information in a Milestone Status 78
deleting 52 Share groups 149
execution order 47 Sharing, definition of 149
for email notification 51 Shortcut menu 69
in Milestone Status views 78 Shortcuts, on the Toolbar 23
mail, definition of 148 Show As, in column set up 60
modifying 52 Sibling header, definition of 150
naming 50 Sibling headers 63
opening 52 Simple search 27
overview of 14 Stacked bar graphs 72
sharing 51 Starting TrackRecord 20
sorting 51 Status
testing 52 bar 25
with Outline Reports 57 changing 42
Status bar, definition of 150
Subproject, definition of 150
Summary of changes 7
R Summary reports 56
Support
Rearranging headers 63 ggmpuware hotline 9
Reconcile 149 FrontLine Website 9

integration with 133
Recurring events, definition 149
Registering builds 137
Related publications 8
Release, associating VCS labels to 132
Remainder header 63, 149

online help 8
using online help 26
Synchronization 123, 125

Report, see Outline Report 111 T

Resources (Project) 121

Retrieving data, overview 14 Tags 145

Right-click menu 69, 149 Task

RTF, definition 149 adding to calendar 84
Run Query Now button 52 assigning priority 121
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basic 32
Team member, definition of 150
Technical support 10
Templates

associating with a header 108

cautions when creating 101

creating 105

definition of 150

description of 101

naming 106

nested order 103

setting default 108

within Outline Reports 103
Testing a query 52
TestPartner

defined 150

integration with 133
Text editor

embedding Outline Report 111

integration with TrackRecord 111
Toolbar

definition of 150

description 23
TrackRecord menu, in Project toolbar 118
Transient sessions, definition of 150
Trend graphs 72
Troubleshooting

DevPartner integration 142

queries 47

Version control systems 133
Types

child 17

definition of 150

favorites 31

inheritance 17

of users 12

overview of 15

parent 17

U

User
description of 13
description of, WebServer 13
interface, described 22
interface, for WebServer 91

types 12
User name 25

\"

VCS 129
associating label to release 132
associating project with TrackRecord 130
checking files in and out 131
definition of 150
synchronizing with 132
troubleshooting 133
Version Control System, see also VCS 131
Version resource strings 141
Viewing
data through calendar 81
data using Outline Reports 55
data, overview 14
milestones 74
online books 8
Views
defined 53
definition of 150
deleting 54
modifying 54
Visual Basic 125
Visual C++ 127
Volatility 76
definition of 150
graph 80
statistics 79

W

WebMonitor, definition of 150
WebServer
canceling changes in 89
Change History 93
control area 91
creating an item 94
deleting attachments 97
description of 87
description of user 13
displaying the database and user name 92
entering information 88
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file attachment requirements 95

file attachments 95

interface described 91

logging in 89

logging out 90

notes 92

opening an Outline Report 98

opening attachments 96

Outline Reports 88

Outline Reports in 98

printing 94

restrictions 88

search 97

status bar 92

work area 92
Workflow Editor

definition of 151

definition of available states 146
Workflow, definition of 151
World Wide Web, Compuware sites 9
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